Trying to trace SMTP send mail failure

Not sure where to put this so I choose uncategorized since it may be a mix of different things.

I have a send reports to e-mail functionality on my Asustor NAS and it should connect to my SMTP server on my webhost and send me e-mail notifications. The SMTP is with authentication and uses port 587 and SSL/TLS.

Don’t really use it much, but came to think of it and testing a bit, the mails do not go thru and I am frankly having a hard time finding any communication attempts from the local IP and port 587 in the logs.

I have no custom firewall rules. Everything that is enabled is based in Intrusion Prevention and location.

For kicks I also tested with Google Mail and trying to send that it fails immediately with an error 5905 that could probably mean anything, don’t know if that is a Gmail error or an Asustor error. I also tested sending via an Outlook account and that works, but not what I need to use.

Any ideas on where to look?

Change to port 465 and test






That’s right! 587 It’s the wrong door. :wink:
I am sure it applies to any SMTP-SSL client/server.

I fear I might not have been explicit enough…

587 is defined by my Web host where the email server is. Nothing I can control.

As for the gmail, sure I can test, but not really the issue. Don’t use Gmail for this.

Also, I know for a fact this worked before l started using IPFire and since I intend to keep the firewall l am looking to solve this issue.

BTW, sending mail via IPFires Mail service works with the same settings and has worked since I first configured it months ago. Port 587, StartTLS, even with explicit TLS .

Ok. So the service is set on 587.
I had misunderstood as well :blush:.
My instinct is to try copying all the Outlook parameters. It works with Outlook, okay?
If the NAS parameters are the same as Outlook and it doesn’t go (as I imagine), I can’t think of any other solution for now :unamused:.

If you seen the e-mail service in IPFire you will know that the fields for that are not many. On my NAS even fewer.

On the other hand I could perhaps setup an outlook mail alias or some such and monitor it that way.

Bugs me not being able to use “my own” mail server though.

So I understand that your client is missing essential server parameters, right? If so, I don’t see much of a solution, other than to “run mail on multiple servers.”
Or try a NAS firmware update. Maybe they have integrated more parameters regarding the mail client.

Not using the NAS as mail server. Only to send me reports. Settings > Notifications.

It did work before IPFire.

Has what is needed.

Something is blocking it and I do not find what.

Reports are not emailed by nas?

Are you using Proxy?
If so try adding the port in the “Allow SSL box”.

No proxy used.

I think the NAS sends the emails. It says it does and I know it has sent them before I setup IPFire. Now they are not getting to the mail server.

So the nas sends emails regularly, but IPFire blocks them, right?
I try to understand slowly with my translator friend :blush:.

1 Like

So it might not even depend on IPFire?

However, if you had the problems after configuring IPFire, I too think there is something wrong with the firewall. I can’t think of anything right now, though.

Something in IPFire is probably blocking it.

It worked before I set up IPFire.

Español. Esto funcionaba antes de poner IPFire en my red, pero lo usaba bastante poco. Hice una revisión de funciónes y probando ésto algo está bloquandolo y ese algo probablemente es el firewall, pero no encuntro nada en el log que me indique de alguna manera si ese es el caso. Eso es lo que busco.

I see. Big problem. I’m just thinking… :thinking:

Sorry, you are Italian… here I was thinking Spanish… which I speak, but is not Italian. :crazy_face: