Trying to trace SMTP send mail failure

Consider that IPFire, in your case, should only be “a gateway”, “pass traffic”.
There are no firewall rules blocking, right?
Really strange.

No problem. I’ll switch to automatic translator :rofl:

Yes, I am Italian and unfortunately it is the only language I speak. :unamused:

1 Like

We are waiting for suggestions from other people. Maybe they will be helpful for me to turn on some light bulbs, too :wink:.

Have you checked logs

1 Like

This just occurred to me:
Could it be that IPFire is blocking your nas local IP (to RED)?
Could you change the local IP address of your nas?
Maybe that could be a clue.
And as @hvacguy says from the LOGs you should see if I am right.

Other clue:
Are you really sure there are no blocking rules in your firewal? Or simple rules that prevent log generation?

@casabenedetti @hvacguy

I have tried to check logs. The NAS has the IP It is static. Everything else works (just saying). When I go in to logs and try to find entries related to drop or blocked or anything on either that IP or the port 587, I find nothing conclusive.

That was also the original question, where should I be able to see if IPFire is blocking access to smtp 587 from Green?

Port 587 is an RFC standard: RFC 2476: Message Submission

There are ways to verify access to that port via telnet but all I am getting is an error so I guess the smtp server has that responsiveness disabled.

There are no additional firewall rules. None whatsoever.

Ok. let’s wait for more suggestions. In the meantime I’ll think about it :thinking:.
If I think of anything else I will post it here.
For now it’s a good mystery :thinking:.

Theoretically only from the logs.

Is it a problem to try to change it temporarily? Just to understand.

Have you tried a reboot of NAS+IPFire?

1 Like

A reboot shouldn’t affect this, but I can try, later.

I would try. A developer friend of mine, when I took a computer science class, told me a joke about rebooting. If you solve it that way I’ll tell it to you :wink:.


And maybe even the router. I’m going to sound exaggerated, but:

  1. At one school they wanted a firewall, and I put IPFire right in.
  2. One day, some sites wouldn’t open.
  3. After much trial and error, I solved it just by restarting the school’s router.

I learned never to take anything for granted.



Did not help.

Even tried changing some parameters like with or without SSL/TSL and replacing hostname for IP address.

Will try more oncoming days.

On a side note, I have a TrueNAS Scale server that does the same thing, send e-mails to my mail server with reports, same settings - different OS, and it works. I will see what else I have that could send reports.

Sure, I could give up and use outlook, but that is no real solution.

1 Like

Could it be a problem with the DNS (or the gateway, or the network mask) set in your NAS?
Are you sure they are set correctly?

Try setting google DNS on the nas:

Other than that I have no other ideas for now :unamused:.

This is the job of DNS.
Theoretically, this should “bypass the dns setting.” But I would do the last DNS change test.

This mandatorily (in the client) must match the server-side parameters.

Also, are these logs ?


Tonight I set it up and it worked


1 Like

I have always configured my IPFire to send emails the same way. And my NAS also sends emails perfectly. Everything has always worked for me. I just can’t get any ideas about the problem. I have CU173.
I want to redo another test right away…

I can confirm that both IPFire and my NAS send emails from GREEN perfectly :slightly_smiling_face:.

Here is how I configured my NAS to send emails with reports (inside the green).
I hope it will help along with the schematics from @tphz
See, my old NAS doesn’t let me configure either port or connection (SSL or not SSL).
And that could be a big problem. But with Gmail it works for me. Your NAS is better than mine, because I see it has more options. Really strange that it doesn’t work for you.

I see now that dropdown about mail System Logs > Settings > Section > Mail. I had completely missed that option. :no_mouth:
At office now so cant check until about 18CET but will.

1 Like