Traffic Counters not updated in Net-Traffic

I’ve been using IPFire for a couple of months and so far it’s worked quite OK.

One of the main issues that I have not been able to figure out how to work around has been that the traffic counters don’t get updated on the Status -> Net-Traffic page.

The other pages that show the graphs for the interfaces are updated however the ones on the Net-Traffic page only have a few dates of data (I assume when the device was rebooted) and most are at zero:

Is there a script or a setting that can be executed/modified that can help with diagnosing this?


The process collectd is responsible for collecting data and then providing graphs.
So, is collectd running on your system? example:

root 2136 1 0 Mar02 ? 00:07:44 /usr/sbin/collectd -C /etc/collectd.conf

Yes, the process is running, however I have not restarted it, yet it has only been running since 20 minutes past midnight (it’s 9pm now here):

ps -ef|grep collectd
root 12529 1 0 00:20 ? 00:01:05 /usr/sbin/collectd -C /etc/collectd.conf

Actually I saw that the root cron restarts it at random time between 11pm and 3am so this is not an issue.

What I see is similar to what is described here:

However in my case there is data for Nov 29 and Nov 30, 2019 and nothing since then.

All of the other statistics are there and I can see the graphs for the individual interfaces (red0, green0, etc).

Just the summary page is not rendering correctly.

I had an open bug for this, but not working dns and firewall logs was more problematic.

remove /var/log/vnstat/tag

Should solve this.

1 Like

Do I have to restart after that? That file was empty here. I can’t see it’s regenerated automatically. The others: blue0, green0, red0 aren’t empty, but they are outdated (09.03.2020, 17:16:11) all with the same time stamp.

Edit: after a few seconds the other files got updated but the filre “tag” is still missing.

That didn’t fix my problem. The net traffic overview is missing many days for me and I compared the pics. Last entry was 09.03.2020 before the deletion, which is obviously related to the last “change date” to that files I just mentioned before. Now there is a new entry for today and the last “change date” to that files changed to today, but there is still everything zeor and blue/green missing.

Edit2: OK need to wait a few minutes. The graphics for blue/green just came back.

How to clean up the old entries that are not correct?

Awesome - this solved the issue.

I removed the file and restarted the daemon after that and immediately (after 30 minutes, didn’t check before) started seeing the counters go up.

Thanks Arne!

@arne_f - do you know where this file gets created?

Everything worked OK for about a week and then the tag file appeared again which prevented the statistics from being generated again.

I can probably add a cron job to delete it every 5 minutes but it would be cleaner to not have the file show up at all if possible.


Yes. I have created this at builttime to include the folder to the cd. This was a bad idea.

Thanks. Indeed I upgraded to Core 142 in the mean time so this is probably when it showed up - I can just remove it whenever I upgrade.