Rpi4 and error -22

Hello , I have a rpi4 (4GB RAM). I installed the ipfire 171 version.
The rpi recognized the sd card with the boot.scr modification. After that I updated to the next version (174) through ipfire.localdomain:444 but after I installed this update I have this error.

invalid bus width
error -22 whilst initialising SD Card

It happens everytime I launch ipfire via SD.

I tried to boot the raspian os sd card and it works well. And Ipfire launches without any issue via usb. I have this problem only using the sd card.
I tried the 171 and 174 version. Do you have any recommendations?

Hello @ulissess - Welcome to the IPFire community!

There are similar issues in this thread. But I dont see a solution in the thread.

And there are some possible fixed in that long thread. It maybe an SD Card or a Power Supply or ?

Do you know what version RPi4B you have?

Somewhere along the way RPi changed hardware (and versions) that may cause issues.

You can read about some of the issues at the top of this page.

Here are the RPi4B boards:

The above is copied from here:

If you can boot via the raspian os sd card, then it is easy to get the board version:

cat /proc/cpuinfo | grep -A3 'Hardware

Thank you for the answer, this is the output of the command…

pi@raspberrypi:~ $ cat /proc/cpuinfo | grep -A3 ‘Hardware’
Hardware : BCM2835
Revision : c03114
Serial : 10000000a1be56b5
Model : Raspberry Pi 4 Model B Rev 1.4
pi@raspberrypi:~ $

I forgot to mention that I upgraded the eeprom too but I have the same error

I edited boot.cmd AND boot.scr and now it works fine via SD.I fixed it !! thank you!
I followed these 2 threats:

thanks for the help!




Fixed the issue at hand. I encountered the same issue (-22 bus width).

Rasp 4
rev 1.5
BCM 2835

Booted and worked for me!

1 Like