IGMPproxy configuration

Please help to configure IGMPproxy (IP/TV), how it is configured at all.


(edited your post, since this is an English-only forum :slight_smile: ) please refer to this wiki page for configuration details regarding IGMPproxy.

Thanks, and best regards,
Peter Müller

1 Like

I can’t figure out how IGMPproxy works if the settings don’t work with my provider

And when IP/TV is turned on, it creates another network interface for some reason, although it needs to use the red network without creating another network.

This does not make much sense, if you want help you need to be more specific.

1 Like

What needs to be done here to make everything work

EDIT : Inserting a picture is preferred to a website link - moderator

I don’t understand the meaning of this file a bit, and how it works, wiki didn’t help me in any way

Start with the topology of your network, explaining what you mean by

and installing igmpproxy if you did not do that already. Do you know how to work with the console of IPFire?

Network topology, Receiving network equipment = switch = PC + Router + TV set-top box

Insufficient information for me. Draw a network, with IP addresses included. Answer the other questions. You write one line, I answer with one line. Almost ready to give up.

1 Like

EDIT: Inserting a picture is preferred to a website link - moderator

1 Like

I assume you know how to work with the console, since you ignored the question.

This is what I would do with your network, however you have to find out from your provider which IPs are multicasting the IPTV stream to you, and are just examples of common IPTV sources. Possibly yours is/are different.

Also, this configuration is going to multicast only on the green network, to the IP address specified in the phyint green0 stanza, under altnet. You can add other IP addresses, if you plan to stream also to other machines. No blue0, no VPN, only green0.

Multicast means that even if the incoming packets are in one stream, they can be redistributed to several IP address by the local router (IPFire in your case). To do this, you need to use the IGMP protocol. In the configuration of the program that does that, igmpproxy, there is an input (upstream), and an output (downstream) from the point of view of IPFire. Both can be one address or several addresses (specified in altnet parameter). Some provider uses VLANS, as in the example of the wiki. In this case there are two network virtual interfaces intermingled into one physical ethernet card. Since you do not have a box upstream of IPFire, I assume you do not receive the multicast signal in a VLAN, therefore the incoming is red0 and not red0.8 as in the wiki. If I am wrong the configuration is more complex and you need to know which VLAN the provider is using.


edit /etc/igmpproxy.conf

## Enable Quickleave mode (Sends Leave instantly)

## Configuration for eth0 (Upstream Interface)
phyint red0 upstream  ratelimit 0  threshold 1

## Configuration for eth1 (Downstream Interface)
phyint green0 downstream  ratelimit 0  threshold 1
       altnet;   # receiver IP  TV set top box
       altnet;    # receiver IP PC

## Disabled Interface
phyint lo disabled
phyint blue0 disabled
phyint red0 disabled
phyint tun0 disabled
phyint ppp0 disabled
phyint imq0 disabled
phyint mast0 disabled

edit /etc/sysconfig/firewall.local

case "$1" in
        ## add your 'start' rules here
        # for igmpproxy
        /usr/sbin/igmpproxy /etc/igmpproxy.conf &
        /sbin/iptables -I IPTVINPUT -i red0 -d -j ACCEPT
        /sbin/iptables -I IPTVFORWARD -i red0 -d -j ACCEPT
        ## end for igmpproxy
        ## add your 'stop' rules here
        # for igmpproxy
        /sbin/iptables -D IPTVINPUT -i red0 -d -j ACCEPT
        /sbin/iptables -D IPTVFORWARD -i red0 -d -j ACCEPT
        killall igmpproxy
        # end for igmpproxy
        $0 stop
        $0 start
        ## add your 'reload' rules here
        echo "Usage: $0 {start|stop|reload}"

edit /etc/sysconfig/rc.local

## net tv setting
/usr/sbin/igmpproxy /etc/igmpproxy.conf &

After you change these three files, you need to start igmpproxy in the background, either in the console enter

/usr/sbin/igmpproxy /etc/igmpproxy.conf &


/etc/sysconfig/firewall.local reload

or in alternative simply reboot. Probably you should reboot anyway.

This setting works for me, no guarantee it will work for you.


iptables: Bad rule (does a matching rule exist in that chain?).
iptables: Bad rule (does a matching rule exist in that chain?).
This is what I have writing after restarting

Everything is written in the console, and for some reason another network is being created

By the way, I also found out the multicast IP address

I have also those since long time. Probably nothing to do with igmpproxy setting.

You have a VLAN in red. I do not have direct experience with that. For sure then you need to put red0.8 in the config, not red0. However I am not sure how you need to put two different ethernet identifier as suggested in the wiki. Maybe someone more informed can give you an advice.

By the way, the comments in your config are wrong, red is upstream and green downstream.

Tell me how to do it?