"wpad" host entry on both green and blue


I ask for clarification regarding the wpad setting in the host entry page. I provide two networks, blue for wlan and green for copper under the same domain name and I wonder if i could use both “wpad.domain.name” under the green and blue network, using the different ip network ranges.

Hello ,

you can define more “wpad” hosts with different IP adresses. I tested that in my test environment and i could resolve the “wpad” host in both networks.


Good afternoon,

thank you for replying. I tried both “wpad” entries for them different subnets with same domains and I have had problems.

I need to admit this problem seemed to appear just on Windows 10 using the Edge Browser, so deleting the “wpad” entry for the blue network and leaving just one seemed to work for me so far.


Hello I just tried the wpad configuration for blue and green and I didn’t have any problems even with edge. Did you configure the DHCP option for wpad?

Good morning, yes I did.

May I please hand you over the wpad config as defined on my iPFire:

— DHCP Options —

wpad “http://III.PPP.AAA.1:81/proxy.pac” BLUE
wpad “http://III.PPP.BBB.1:81/proxy.pac” GREEN
wpad code 252=text Definition


III.PPP.BBB.1 wpad domain.name No

So, when adding a wpad entry as shown below, Edge stopped working on GREEN.

III.PPP.AAA.1 wpad domain.name No

That’s just how I configured my system.
Difference: PTR is generated for hosts.

Good afternoon,

III.PPP.BBB.1 wpad domain.name Yes
III.PPP.AAA.1 wpad domain.name Yes

don’t work. I presume two “wpad.domain.name” with different IP subnets are not that managable.

Furthermore I had had already tried e.g.

III.PPP.BBB.1 wpad_green domain.name Yes
III.PPP.AAA.1 wpad_blue domain.name Yes

but I understood from googeling that some solutions catch data from http://wpad/ or so.

I deleted the BLUE entry and it works again. Don’t want to stress that too much, so thank you much for yours information.

I use two different domains for green and blue.

Did this today morning and it worked. Thank you for clarifying.