Wio addon broken - can't change anything

I am using “Who Is Online?” since a long time but it seems it’s broken now.
Every time i try to edit something, i get this message:

This function is temporarily unavailable, because in the background client states are being updated (active/inactive).

I did a reinstall to see whats going on but no luck - i cant change/edit/add anything…

What did you change at the time that wio stopped working.

What does the who is online entry in the System Logs show.

What messages do you get if you do a grep for wio on the /var/log/messages log file

I changed nothing on wio itself.
The IP of my server changed and i tried to add the new IP

Log says:
12:52:18 wio: could not lock RRD - thats all

I have no idea where to look with regard to that error.

@sfeddersen will have more clues if he sees your message as he is the creator of this addon.

Ok - thanks for this Info - lets see :+1:

So… no infos from the dev… any other suggestions for me please?

What is the output of
ll /var/log/rrd/wio

1 Like

1.rrd - 26.rrd
maybe files…

Yes, you are right.
But, I asked for the whole output of the ll cmd. With ownership etc.

Ah - ok, sorry
The ownership is on every file the same:


file rights in /var/log/rrd/wio should be root.root / 0644 for all *.rrd-files.

Another idea:

Stop ‘wio’ by deactivating it on the configuration GUI.

Check contents of directory /var/log/wio.


-rw-r--r--  1 nobody nobody  1862 Feb  5 13:02 .arpcache
-rw-r--r--  1 nobody nobody  4344 Feb  8 21:11 wioips

If there is a file named wiofile or wioedit in this directory, try:

unlink [FILE] and delete it


Yes they are all root.root
The point is, i tried to stop wio but no luck - thats not possible…


This function is temporarily unavailable, because in the background client states are being updated (active/inactive).

This was the reason why i tried to reinstall it…
And no, there are no such files at the wio-dir

Is wio.pl running?
This process should only run every x minutes ( x configurable ) for a short time.

Is running - as root
Time Interval is set to 15min

EDIT: wio.pl is now running twice - lol? Is this normal?
Its seems, this processes are hung - both are still active - now over more then 10min…

Killed one of the two - the other is not killable at all - still running…

Ok… this addon is not working so i delete it…
I have not time for this…

After deinstallation, wio.pl is “still running”… in “two” processes…
There is def. something really wrong with this addon :crazy_face:

Just kill these processes before a new installation.

What kind of clients did you define to be watched?
Maybe there is a problem causing wio.pl to wait ‘endless’.

Its not possible to kill this process… dont know why…
The watched client is my Plex-Server which is running normal.
But now its gone - after more then 10min

I have probably found the cause/solution

On some IPFire devices, there may be a problem with the command

wioscan -s red0

Below are the results from a test IPFire on VM


Below are the results from the problematic IPFire device

Multiple IP addresses assigned to one MAC address.

It seems that with so many addresses, the wioscan -s red0
command does not terminate (hangs).

I am not a programmer :frowning: , and to get around the problem,
I commented out three lines:

#if ( $netsettings{'RED_TYPE'} eq 'STATIC' || $netsettings{'RED_TYPE'} eq 'DHCP' ) {
# push (@ifaces, "RED");

in the file:

The author(s) of the script and people more experienced in IPFire programming, I would like to ask for analysis, checking and possible correction.

Best regards


Hi tphz,
thanks for this info.
With these three lines commented out, the plugin is accessible again - so there is def. an error in the script :+1:t2: