Unable to get DHCP Server to start

I’ve re-installed IPFire as I saw in several posts others have fixed their install with the DHCP server to start, mine just fails. I know that I have the RED working, as it successfully starts and I’m pretty sure I have the GREEN connected too, as there was a command (forgot it now) that I could to see if it was linked, which said “Yes”.

So now I’m down to asking you Guru’s what could be my issue - I’ll try to provide screen shots of the setup as I can, for the IPFire, I’ll put in what I have done.

My setup - GREEN + RED network. The RED will connect to my CenturyLink Router/Modem and below are screen shots of the setup (if you want to see something else, let me know what and I’ll get a screen shot). The GREEN network will be connecting to a Router that has a LAN and Wireless for it.

LAN Settings on Cable Modem - CenturyLink - RED

DNS Settings on Cable Modem - CenturyLink - RED

DHCP Reservation State - CenturyLink - RED - not for sure if this would have an effect or not…

Upon booting IPFire it has the following:

  • Starting dhcpcd on the red0 interface…
  • DHCP Assigned Settings for red0
  • IP Address: 192.168.0.4
  • Hostname: hmm - do you really need this???
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.0.1
  • DNS Server: 192.168.0.1 192.168.0.1

The Main page of the Router setup - model displayed if that helps - GREEN

WAN Settings page - GREEN

LAN Setings page - GREEN

DHCP Server settings page - GREEN

I’m not an expert on Linux, so I’m not for sure how to get to the WebUI of the IPFire, nor have I dug to see how to do it. I can get around easily with a bit of guidance and hopefully if you need more information, I’ll get it and post screen shots if possible, otherwise I’ll type it in.

Thanks, Michael

Where is your IPFire in this network(s)?

1 Like

Guess my post wasn’t all clear - updated the orginal post of the images of what network they belong to.

IPFire of setup I can see now:
hostname:ipfire-widget
domain name:widget-domain
GREEN IP Address: 192.168.0.1
GREEN Network Mask: 255.255.255.0
RED: DHCP
RED DHCP Hostname: ipfire-widget
RED Force HDCP MTU: 'blank"
RED IP address: 0.0.0.0 - cannot edit this
RED Network Mask: 0.0.0.0 - cannot edit this
Gateway Default settings: “blank”

Hopefully that makes it a bit more clearer…

Michael

You have a network conflict between red and green.

If you modem use 192.168.0.x you cannot use the same subnet on green!

1 Like

So, change one of them should take care of the issue then…

Once I’m done with work, maybe I’ll get a chance to change it…

On the LAN Settings page for GREEN network, I changed it to 192.170.1.1, then for the DHCP Server Setting page - GREEN, those adjusted to having the last number match what the screenshot above shows, but it is 192.170.1.15 and 192.170.1.80. I also went into IPFire setup and changed the IP Setting there to 192.170.0.1 - rebooted and still not able to get DHCP to start.

Is there something else I’m missing - I know I’m not understanding it as if I did, I wouldn’t be asking these silly questions.

Is there any other commands I can do on the IPFire box to get more information?

Thanks, Michael

Usually your DHCP server is the Same as your IPFIRE Green Address.
Like 192.170.1.1/24 for Green
DHCP 192.170.1.1
IP Range start 192.170.1.10
Ip Range end 192.170.100

The address for GREEN is used in more than one config file. It would be simplest to reinstall, using your new setting for GREEN. Be certain to enable DHCP at the final screen in installation, again using addresses consistent with your new GREEN.

Another thing ( not negligible! ):
Please use a private network for green. 192.170.1.0/24 is not private.

I couldn’t see, where your IPFire is located in your network, yet. You posted configs for your modem router and your internal router.

Having read through this whole thread a few times, I believe that what @schumacher777 is trying to do is the following.

Internet -> CenturyLink Cable Modem -> IPFire -> ASUS RT-AC66U

I believe that the ASUS router is being used just as a wireless Access Point and the WAN connection on this router is not being used.

@schumacher777 indicated in his original post that he has not been able to access the WUI and so I believe that he is trying to do all the configuration from the IPFire console command line using the setup program.
@schumacher777 please confirm if my above understanding is correct or not.

Information for how to login to the WUI is in the following wiki link
https://wiki.ipfire.org/configuration/login

From your screenshots of the ASUS router you have also enabled the dhcp server on this. This would then give you two dhcp servers on the green network (if my earlier understanding of your network topology is correct) which is also not a good thing. Just use the dhcp server in IPFire

I think my recommendation to you would be to start at first with just the centurylink modem connected to IPFire and with a pc or laptop connected by ethernet cable to the IPFire green connection.
With this you can then access the WUI and get the configuration setup as you want and then you can add the ASUS router (WAP) and configure it.

1 Like

Correct

Correct

Okay - so, disable the DHCP on the Asus router, make it static of a private network address - have to figure that out…like I said, I’m not a network guru at all.

I’ll try this too - just hoping to get further this time…

You must not be a network ‘guru’, it is enough to know network basics.
Can you explain how your local netork is structured and why? Often such an explanation gives knowledge to the explaining also. Just my experience in many many years of SW develpment.

1 Like

The cable modem/router is with CenturyLink - which currently serves the whole house wireless and one lan connection for work. The reason I’m introducing the IPFire into the mix is to prevent my kids from getting to places they shouldn’t be accessing. Mainly the drive was my middle son watch a youTube video that scared him silly at night and had several nights that he had a terrible time going to bed. Yes, one can control the devices that are in the household, but one cannot control devices that belong to the school or friends that come over. The Asus router will be connectted to the IPFire to give the wireless access and the lan connection if need be for other devices in the room. My plan prior to all this was to add another access point that would give better reception for the wireless, as the current centurylink modem is poor in reception through the house.

Plus with the learning I’m doing on setting this up, I’m picking things up here and there…

If you want to control internet access, especially for the kids, you should open the first access point with/after the control unit. This unit is IPFire if I interpret your description right.
Thus the connection between WAN and IPFire should be straight through.
WAN(your internet access) <–> CenturyLink <–> IPFire <–>ASUS <–> local network.
The CenturyLink device should do not more then conversion of WAN connection to ethernet/IP.
IPFire is the ‘real’ WAN access, RED interface connects to CenturyLink by DHCP on wired ethernet, GREEN is the connection to the local network ( wired ethernet to Asus, and/or working computers ).
Asus implements the access for the house hold, building up a wireless network for all other devices.
With this you have to control internet access for the kids on Asus. If you want it to do on IPFire Asus router must be connected at a separate BLUE interface ( ethernet ) and must be set in bridging mode.

About IP / DHCP settings:
RED network, defined by CenturyLink
GREEN network, some private net, like 192.168.10.0/24, not network of RED, if RED is DHCP.
BLUE network, some other private net, distinct from RED and GREEN.
Depending on the configuration this must be set on CenturyLink(RED),IPFire(RED/GREEN/BLUE) and Asus(GREEN/BLUE).

About workflow:
It is best to setup IPFire from the command line with the minimal config possible in setup. After definition of a GREEN net all other configurations can be done through the Web User Interface from a computer connected per wire to the GREEN inerface/network.

1 Like

Michael …

Internet -> CL modem/router/wifi -> ipfire -> asus AP

CL modem/router/wifi

WAN public from CL
LAN 192.168.0.1
DHCP 192.168.0.10-200
SSID home

ipfire

RED 192.168.0.2 (static)
GREEN 172.16.0.1
DHCP 172.16.0.10-200
DNS 8.8.8.8

ASUS configured as AP

WAN no
LAN 172.16.0.2
SSID kids

people can connect to ssid HOME and access the Internet
(they will get an ip in the range 192.168.0.10-200)

kids can connect to ssid KIDS and access the Internet
(they will get an ip in the range 172.16.0.10-200)

In order to see the ipfire GUI (https://172.16.0.1:444), you need to
be part of the GREEN network (connect to ssid kids)

In order to see the CL modem (http://192.168.0.1), connect to ssid home

I hope this helps.

1 Like

This may help with the ASUS router as AP

I’m trying to set up the following, but not having any luck. The part that isn’t drawn is the WWW…

Using the “plan” from @pavlos, I re-installed IPFire setting the RED to static with IP address 192.168.02 and network mask of 255.255.255.0

The GREEN is set up as 172.16.0.1 with a network mask of 255.255.255.0

Going into the ASUS router, setting it as AP and currently setting the IP to 172.16.0.10

At one point, I think I had the ASUS router set to automatically get an IP and at that point I was able to connect through the ASUS, through IPFire to the setup of the Century Link Modem.

My issue is with the current setup the RED cannot see out, I cannot ping 8.8.8.8

While looking at the Century Link modem setup pages, I found the following of DHCP Reservation list - I see my ipfire listed, but it was at 198.162.0.4, so I removed the list, manually assigned the mac address 198.162.0.2, rebooted the IPFire and now it is 198.162.0.2, but still cannot ping 8.8.8.8

Century Link Modem - Current

DHCP Settings - Century Link Modem

WAN Settings - Century Link Modem

ONE THING - after setting the ASUS to AP mode, I cannot get back to the settings. Should I be able to do so? I would think I could, but for the life of me, I cannot figure that out of how to do so, but will go onto their site for the thing and read documentation…

Yes from green log in using ip you set in ASUS router/AP.
Make sure Ipfire has not allocated ip to something else.
DHPS in ipfire set to start at 172.16.0.20 to 172.16.0.254
Then Check you DNS system in Ipfire.

Michael, I assume the work laptop is the one you’re working on. Since it gets an ip 192.168.0.* from CL (either wired or wireless), it should be able to ping outside (the CL DNS handles that). If you cannot ping outside, the CL configuration is not ok.

You need to adjust the DHCP range in CL, I suggested 192.168.0.10-200, leaving 1-9 for static ip’s. Ipfire is assigned the .2, maybe your work laptop gets a .3

If the work laptop connects to ASUS (wired or wireless), it should get an ip in the range 172.16.0.* If it does, then you can access the AP with http://172.16.0.10 (both belong to the same subnet) and similarly, you can access the green network of ipfire https://172.16.0.2:444

1 Like

@paul - incorrect, I’m working on my personal laptop, connecting wireless to either the CL or the ASUS.

I’ve been able to confirm that the ASUS is setup as AP at 172.16.0.10.

Using the personal laptop (running windows 10) to connect wireless onto the ASUS. Upon doing that I’m getting assigned the 172.16.0.180 address. I’ve done “ipconfig /release” and “ipconfig /renew” and follow up with “ipconfig” shows I’m connect with that IP. While still connected to the ASUS, I can connect to the 172.16.0.10 and view the setup page now of it, through it I can verify that it sees the IPFire.

Also, while connected to the ASUS, I can also get connected to CL (192.168.0.1) just fine. Now while on the IPFire machine logged in as root, I cannot ping 8.8.8.8 on it. Hence my issue of the setup. Something just is quite right on that machine to let it get out. The DHCP range is set to 192.168.0.10 to 192.168.0.200

I’m at a loss of why the IPFire cannot get through the CL to the WWW…

If there are some commands to run on the IPFire and screen shots, please let me know. Now I should be able to use Putty to ssh over to the IPFire box, that way I can get screen shots of it, correct?

Thanks SO much for you help - greatly appreciate it!