Troubleshooting Internet connectivity

What logs should I look at?

I got a weird issue, I have been looking through some logs but can’t find anything. I think IPFire doesn’t resolve my only 2 wired devices.

I can’t reach internet on 2 devices,
Wired Raspnerry Pi (RaspbianOS)
and a Smart TV(proprietaryOS)

Wireless devices .have no issues.

All wired and wireless.devices are all plugged into a wireless AP,

Wifi AP is connected to GREEN. so IPFire shouldn’t treat WIRED devices any different.
There is no VLAN. and there is no BLUE.
Just RED and GREEN.

Wired Raspnerry shows
'Temporary failure resolving ""

Wireless Raspberry resolves fine.

So I looked through logs
Logs-Firewall Log , nothing shows up with the IP

Logs-SYstem Logs - Unbound` shows no issues

IPS Log shows
GPL ICMP_INFO PING *NIX coming from the RaspberryPi IP`

So I disabled that ET rule,

I even disabled IPS, still can’t resolve any domains.
I could ping an IP outside IPfire but can resolve it.

THey have the same DHCP and DNS settings
/etc/resolv.conf .
I even hard coded DNS, and tried a few public ones, but no trace of any issue…

I have a similar setup except I don’t have any wired devices connected to WAP.

All works OK for me.

Thinking out aloud…

I have:

  1. WAP and IPFire are bridged.
  2. DNS & DHCP & NTP served from IPFire.
  3. All configuration was done via WUI (I did not have to go into any config files under the hood).

This error message 'Temporary failure resolving “” to me suggests a routing issue between WAP to IPFire.

Question 1… are your wired & wireless devices on the same subnet… or does your WAP have wired and wireless devices configured in separate subnets.

Question 2… are your wired devices connected directly into LAN ports or do you have a switch connected into WAP with wired devices hanging of it?

If this was my problem I’d have a network diagram in front of me doing further troubleshooting on and from the WAP itself.

If the IPFire was blocking traffic from a wired IP then this whould show up in Firewall logs which you say it isn’t.

If you do have a basic diagram with IP addressing scheme this might help with further ideas.

I’m curious if you have made any progress since logging this issue here.


1 Like

Hi Robert, I appreciate your kind reply.
There is no separate subnet or a switch, and the WAP does NOT have any ‘Wireless Isolation’ or anything like that.
The only 2 Wired devices are connected directly into LAN ports

I wish I could find a tail log for the unbound that shows something

So let me make a network diagram and get back to you
Thank you again

Happy holidays.

Hi Trish,

Again… thinking out aloud:

Unbound log messages can be found here:

Under the hood I believe Unbound messages can be found here: /var/log/messages

If wirelss & wired devices are on one and the same subnet and wired devices are showing different DNS behaviour to the wireless devices then I’d be double checking their local DHCP / DNS settings for any discrepancies compared to the same settings on your wireless devices.

Diagrams and screenshots of relevant IPFire panels (eg: DNS, DHCP, Firewall rules etc…) always help those here in the fourm willing to chip in with further troubleshooting tips.


Thanks Robert,

I did look through the Unbound-System Log, but it didn;t show anything I wish It would log every request to resolve a domain…

I think there was something else going on.
Over the weekend, I decided to shutdown and reboot the firewall through System-Shutdown .

Not a good idea, suddenly no devices were able to connect to the internet. I couldnd even SSH, or WebGUI into it. Power light was ON, but both Ethernet Ports were OFF,
Even multiple hard resets, wouldn;t do it .

So I had to get my serial port cable and see what’s going.
I saw DHCP and DNS wouldn’t start and bunch of saw errors:
unbound: [11187:0] error: SERVFAIL

reboot, and same thing happened so I ran ‘setup’
and realized both RED and GREEN are not assigned anymore
kind of weird,
I assigned them as before and all seems to be good now.

I am on IPFire 2.25 (x86_64) - Core152 if that’s useful for anyone.

Who knows why RED and GREEN did what they did.

A glitch in the matrix perhaps.

Good to hear all working again.

1 Like