Starting with IPfire on the RPi4B revision 1.5

Hello IPfire Community

What a great tool IPfire sounds to be. Unfortunately, however, after spending hours trying to set up and reading various forums, including the Wiki, I’m unable to get IPfire to work on my RPi4. So, I wonder if you’d help clarify a few points:

  • Downloading an image onto the SD card doesn’t seem to be working on my RPi4, no matter what card I use. There’s an endless boot thingy (error -5 or something). Downloading an image onto a USB drive seems to be working in that I can load IPfire and try to set it up. I’ve found this post (Raspberry Pi 4 Model B Rev 1.5 - error -5 whilst initialising SD card - #7 by wiesel), but building an image is beyond my ability at the moment. I hope that this doesn’t also mean that I should not be using IPfire because it’s meant for an advanced user.

  • Not sure what I’m doing wrong, but I’m unable to set the red zone. My set up is:

a) a Fritzbox 7530 connected to a DSL line (VDSL profile 17 here in the UK; dynamic IP address) which functions as both a DSL modem and router;

b) a RPi4 running IPfire is then connected to Fritzbox via an ethernet cable;

c) I also have Devolo Magic 1 adapters (LAN and WLAN) and I used the WLAN one to set up IPfire (by having an ethernet cable connected to its LAN port), given the distance between my TV used to set up IPfire and the Fritzbox. I chose the ‘bridge’, then when it didn’t work, ‘PPPoE’ options, but neither seems to be working in that when I try to set up the red zone, nothing comes up. All I can set up are blue and green zones, or a green one, if I choose the red + green set-up. When I eventually log into GUI, I see ‘Connecting’ for the red zone. My Internet is intermittent then, and my partner is complaining that ‘There’s no Internet’, and I’d rather avoid that (i.e. the complaining)!

(I think it’d be very helpful to have some examples of set-ups as part of Wiki, say with common routers like Netgear, Fritzbox and/or Draytek.)

  • the next problem that I’ve encountered is the ‘green’ and ‘blue’ zones. I understand that both can be merged and used as one pool of addresses (192.168.1.x), but if I assign ‘ethernet’ to one, but not ‘WiFi’ to the other, does that mean that IPFire is going to firewall devices connected to either ‘ethernet’ or ‘WiFi’ only? I have a mix of devices with my CCTV being connected directly to Fritzbox, while Chromecast and others to either Fritzbox or Devolo Magic 1 WiFi adapter, the latter of which then connects to Devolo Magic 1 DLan to then connect to Fritzbox.

  • I can’t always access GUI, with a message ‘Connection refused’ appearing if I log into ( is Fritzbox’s address).

  • Once I got access to the Internet, I tried to set up a DNS server (Cloudflare), but I get a message about ‘reverse lookup failed’ and its status is either ‘broken’ or ‘error’. I’ve found this post (Yet another DNS reverse lookup failed), but my set up is much simpler than that discussed there.

Thank you for your time and help. Any insights/helpful comments will be gladly received.

Hello W G @edinburgh_wg - Welcome to the IPFire Community!

with some revisions of the RPi4B it is more difficult then other RPi4B revisions. I have an early revision, so RPi4B was fairly easy.

Please read through this Wiki page:

And this Wiki page:

If these do not help, then we need figure out what version/revision of RPi4B you own.


Hello, and thank you for the welcome!

I have version 1.5 :fearful:

I had read the Pi4B wiki and some of it had helped. (By the way, the link to the downloads page on that Wiki is broken.)

I’ll try to apply the advice on the scenario page. If unsuccessful, I’ll come back.

Thank you for your help!

I think I fixed the correct link. please check and let us know.

Since you have revision 1.5 you may need to following the instructions for revision 1.5 users (the link is the 1st one in your original post)

@arne_f - is there any update the IPFire code for RPi4B that would help with revision 1.5?

I don’t know but there are some new firmware files from the Raspberry Pi Foundation. But i have no
hardware to test.

Also you can try to boot from a USB Stick instead of a uSD Card.

Hi Both

Thanks for your help.

Indeed I’m using a USB drive (in fact a few, as I thought they may be faulty because the GUI didn’t load).

No luck, otherwise. Anyone else with RPi 1.5 having difficulty or is it just me?

@wiesel is one person with revision 1.5. Hopefully he will respond.

see this post (and all of the posts above it):

also here are some searches I did.

for raspberry pi "1.5" :"1.5"%20order%3Alatest

search for rpi "1.5" :

1 Like


Thanks for your support.

Just wanted to report on the progress. I’ve successfully managed to boot from the SD card on RPi 1.5 and to do so, I’ve done the following (for future reference):

  • ‘burn’ the flash image for ARM architecture from the IPFire website
  • done the following:
    a) edited the config.txt file by adding hdmi_safe=0 to the end
    b) edited the uENV.txt file and change SERIAL-CONSOLE=ON to OFF
    c) deleted the boot.scr file
    d) edited
booti ${kernel_addr_r} ${ramdisk_addr} ${fdt_addr_r};


 booti ${kernel_addr_r} ${ramdisk_addr} ${fdt_addr};


booti ${kernel_addr_r} - ${fdt_addr_r};


booti ${kernel_addr_r} - ${fdt_addr};

No need to rebuild the image!

However, I’m still stuck on defining the red zone, i.e. the type of connection with Fritzbox - does Fritzbox need to be in the bridge mode, which it doesn’t support anyway?

It’d be helpful if there were some simple guides available illustrating potential uses. Just for a selection of more popular routers, such as Draytek, Asus, TP-Link etc. (something similar to this: Fritz!Box (EN) - Pi-hole documentation. or this [Wireless Router] How to configure Router to use Pi-Hole? | Official Support | ASUS Global)

EDIT: mod updated code blocks

There are two possible setups:

  • fritz!box in router mode: This is needed if you want still use the telephony on the fritzbox but it has double nat. (so you may get problems with opening ports or vpn’s)
  • fritz!box in fullbridge mode: In this mode IPFire build up the PPPoE connection and get the public ip.

Router mode:

  • your green network could not have IP Range or unless reconfigure the fritzbox.
  • red is configured to DHCP and should get the configuration from the fritzbox.

Fullbridge mode:

The normal bridge or pppoe passthrough will not work because the fritzbox filter some pppoe packetes due a bug. (e.g a dnskey query for the “.” zone)


@arne_f - why does the image not need rebuilding? isn’t boot.scr needed?
I see this at the end of boot.cmd:

EDIT: does auto create boot.scr when it is missing?


What I meant was that it booted without the image being re-built.

I had deleted the file because that conversation in the link says so, although the advice thère is to rebuild the image.

I didn’t do it because rebuilding is beyond my capability.

But it’s worked without rebuilding the image, though I’ll repeat everything once more to be sure (I only tested once).


1 Like

The RPI4 support two boot modes. The first use the boot.scr and always use the uSD card. If this mode fail it fallback and try to boot via grub. So you can speedup the bootprocess on USB by deleting the boot.scr (and this also works around other uSD loading bugs.)

The change from ${fdt_addr_r} to ${fdt_addr} also result such boot fail and the fallback to grub. So it does the same like eraseing boot.scr

On RPI4 you can erase boot.scr but we cannot ship the image without because all other supported boards need it.


Thanks for the explanation.

So, can there be so e kind of condition added: if RPi 1.4/1.5 … then …, otherwise …?

I have no infos how i can detect the version in u-boot at the moment.