Starting DHCP Server fails

I have a R86s G1. It has 3 I225-V ports and 2 Mellanox X3 ports. I want to connect the R86s via one of the I225-V ports directly to the fiber ONT (Deutsche Telekomm). According to the ISP I have to use PPPOE with Vlan Tag 7. Further want to connect one of the Mellanox ports to a Zyxel XGS1250-12 on the first floor and the other one to another Zyxel XGS1250-12 on the second floor. Over the two remaining I225-V ports I would like to connect two wifi asscesspoints.

Now I tried to install IPFire on the R86s, but I have problems to get it running correctly. The two Zyxel XGS1250-12 and the two WiFi asscesspoints can be quiet in the same network so I thought of a simple red and green configuration would be good to go. What surprised me here is that I can only assign one nic to green and one to red. Is that correct? Nevertheless I assign a I225-V to red and a Mellanox X3 to green. Then I followed the WIKI and chose PPPOE.

But now it seems that no DHCP server is started. “statring DHCP Server” shows fail and I get the message: “chmod:cannot access ’ /var/run/’ : no such file or directory”
I assume I did something wrong with the configuration. Do you have any idea where I can start looking for the error?

BTW: I have no IT background, I thought it would be a good idea to learn something new with the R86s. So I hope for your patience :sweat_smile:.

Welcome to IPFire, @neum

Looking at the docs of the board, I can only see 3 NICs. Are you sure, to have connected red and green the right NICs?

Errors in starting up dhcpd should be documented in /var/log/messages.

OK the first problem is solved. I reinstalled IPFire again and now the DHCP server starts. Unfortunately I can’t say what exactly the problem was, in my opinion I proceeded identically :man_shrugging:.

Now I have the next problem. The ISP (Deutsche Telekom) requires a WAN VLAN ID 7. Maybe I’m blind, but I couldn’t find a way to set it in the web interface?

Go the WUI menu item Network - Zone Configuration

Select the RED zone and change Native to VLAN via the drop down box and enter the ID number in the box alongside. Then press the Save button

You will then need to reboot for this change to take effect.

1 Like

Unfortunately, this does not seem to be possible. If I use PPPOE as dial-up method (which I have to do according to ISP) then I have no possibility to select anything.

Maybe this thread can help a bit.
Another helpful thread may be Unable to connect to VDSL - Timeout waiting on PADO packets


Thx, @bbitsch ! I changed the dial-up method to VDSL and now it works. Maybe a stupid question but does the dial-up method VDSL have any disadvantage on a fiber connection?