IPFire directly connecting to the Telekom fiber modem


I´m trying to get our new Telekom fiber 1000/200 connection to work directly with the IPFire.
So far I tried the following:

Fiber modem → Digitalisierungsbox Basic (Telekom router) → PC → speed test bandwith 950/200 → all good

Fiber modem → IPFire dialup using VDSL Template → PC → speed test bandwith 350/250

So I can connect with our credentials but the speed is not right. I found out that the max general VDSL2 bandwith is about 350Mbit? Maybe just a coincidence.

If I choose the PPPoE template it´s not connecting, i guess it needs VLAN 7?
After installing the IGMPProxy the option to use VLAN 7 is there but it is still not connecting. → “Timeout waiting for PADO packets”
Do I need to edit the IGMPPROXY.CONF or is this just for ipTV which we dont need?

Test setup IPfire Update 155 / i7 / 8GB / SSD

Is someone using a similar configuration, I am open for any suggestions.


Did you try a simple DHCP connection from IPFire to the fiber modem?? I’m on deutsche glasfaser and here it’s dead simple just DHCP…

BTW: The IPFire nic must be gigabit ready!


1 Like

Thanks for your reply, sadly DHCP is not working. All gigabit nics.
I think dialup is the right way, almost works…just needs some adjustments…


Hi @kubo

Your Telecom company should tell you what connection process you should be using to connect to your fibre modem.

If it is not in their website then contact them for the information.

Called Telekom maybe someone from IT will call back… but because the router they provide is working the guy on the phone said it might be difficult to get someone to look into it…

The PPPoE connection is now working (not using the VDSL template).
This entry in the log is showing the max up- and downlaod i guess SRU=275000#SRD=1099607#

14:10:35 pppd[1631]: CHAP authentication succeeded: SRU=275000#SRD=1099607#
14:10:35 pppd[1631]: CHAP authentication succeeded
14:10:35 pppd[1631]: peer from calling number AA:AA:AA:BF:50:AD authorized
14:10:35 pppd[1631]: sent [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns2>]
14:10:35 pppd[1631]: rcvd [IPCP ConfReq id=0xe2 ]
14:10:35 pppd[1631]: sent [IPCP ConfAck id=0xe2 ]
14:10:35 pppd[1631]: rcvd [IPCP ConfNak id=0x1 ]
14:10:35 pppd[1631]: sent [IPCP ConfReq id=0x2 ]
14:10:35 pppd[1631]: rcvd [IPCP ConfAck id=0x2 ]
14:10:35 pppd[1631]: local IP address XX.XX.XX.193
14:10:35 pppd[1631]: remote IP address XX.XX.XX.73
14:10:35 pppd[1631]: primary DNS address XX.XX.XX.188
14:10:35 pppd[1631]: secondary DNS address XX.XX.XX.142
14:10:35 pppd[1631]: Script /etc/ppp/ip-up started (pid 1677)
14:10:52 pppd[1631]: Script /etc/ppp/ip-up finished (pid 1677), status = 0x0

Bandwith still at 350/250.
Same with update 156.
Any ideas?

Do you have the Intrusion Prevention System running. This consumes a lot of processing power and can reduce the bandwidth depending on the hardware you are using.

I have a Gigabit glass fiber connection also and if I run that without the IPS enabled then I get close to the 1Gbit rates. With IPS enabled then my bandwidth drops significantly to around the 350 to 400 Mbit level. I will need to look at more powerful hardware if I want to maintain my 1Gbit performance

In terms of PPPoE I don’t have any experience. I am using a plain simple DHCP connection like @odongarma

Thanks for your reply, there is nothing running on this fresh intsalled test system, power should be ok:


Well for the test setup I used a USB to Network adapter (Gbit) which is somehow limited to 350 Mbps…
So it was a hardware issue thanks for pointing in the right direction, now speed went up to 600/250 still not there but getting closer.
It seems I need to focus more on the hardware, this is our live IPFire:
Meybe time for a upgrade?

A bit off topic, the ping went from 6-7 ms on the provided Telekom router up to 18 ms on the IPFire, can you reach those values with improved hardware?