Serial Console Unreadable during pc engines apu1d4 install

Hi.

I’m trying to install ipfire on my apu1d4. I’ve already made my installation media from the iso image and a 4GB USB stick.

I followed these instructions (For Linux in my case):

Then I opened the serial console on my machine.

For that I followed these instructions (For Linux in my case):

I can properly see the machine booting as far as the BIOS and POST happening after that the serial consoles output becomes unreadable.

Here is a screenshot of the issue:

Thank you in advance for any help with this issue.

You have to properly configure the serial console program you are using:
Baud: 115200 ← most important
Data Bits: 8
Parity Bit: No
Stop Bit: 1

For linux console, see this tutorial.

I believe I have the correct settings in my serial console program.
Here’s the command I’m using after I connect the serial adapter.
sudo screen /dev/ttyUSB0 115200

I’m checking out that link as well.

try this:

sudo screen -t 'ttyUSB0 115200 8n1' /dev/ttyUSB0 115200,-ixoff,-ixon

I tried it and I still have the same result. I did notice with both my first command and the one you posted. I can see isolinux 6.04 but nothing else.

Other times I’ve used the serial console with this machine I haven’t had any problems. Systems such as smoothwall/pfsense/opnsense etc all work fine with either minicom or screen. It just seems to be centered around ipfire.

I have used both apu1 and 2 with the null modem usb adapter sold by PCEngines (on a macos serial console) and never had any problem.

which image did you download?

This one.
https://downloads.ipfire.org/releases/ipfire-2.x/2.27-core162/ipfire-2.27.x86_64-full-core162.iso

the iso is correct. I would check the sha256 to make sure there was no error in the download and try to flash again on a different usb stick the image

1 Like

I checked the sha256sum right after I downloaded it and it matched. Could the flash image help in this case or is that for media that can’t withstand many writes?

I will try another usb stick then.

If you start your apu1 machine without any media, do you see the firmware prompt?

Yes I do see the BIOS it then loads the OS I have installed. I currently have pfsense ce 2.5.2 loaded on it and I installed that via a USB stick and serial console just fine. I even used the same USB stick I’m using for ipfire right now and I didn’t have this issue.

Then it mast be the install media, as the ISO I am pretty sure is working.

I will add that this USB stick with ipfire on it boots in my x86_64 laptop just fine. So I definitely think it is serial related.

Just in case, a different, older ISO? Could be a bug? Last time I installed from an ISO on my apu2 was a couple of years ago.

I checked, last time I installed successfully IPFire on my APU2 was core 158. Maybe you can try with that one?

Edit: added link to the iso

Alright I’ll give that a try and see. Thanks.

I’m flashing it now.

FYI:
The version I installed on my APU2 was 161.
No problems.
I just checked. isolinux.cfg contains the baudrate setting to 115200. So it just work for you also.