Random Number Generator daemon

The RNGD browned. Any idea about fixing that, and getting it green again?
Startup shows RTNETLINK no such file or directory. Is that a relevant fact?
Startup shows Initializing kernel random number generator in green and Entering run level: 3erator Daemon. Is that correct?
Shut-down shows saving random seed and Connection Tracking Daemon not running warning in yellow
The Kernel System log recommends running fsac. Attempting to run fsac from root yields mounted can not run.
ARE ANY OF THESE RETURNS RELEVANT TO GETTING THE RNGD to run?

In order to run fsck on partitions, with the disk in place, you would be to boot an external program such as gparted-live.

Alternatively move it to another PC that is running Linux. Attachment via USB would suffice.

Thank you for your reply. Unfortunately my location
doesn’t have access to gparted-live or another PC.

I would have expected the ipfire startup procedure to
make its own repair. I’ve rebooted frequently but
apparently that isn’t the case.

The question remains if the fsck action would fix the
RNGD off status. I’ve sent many requests to Support
without an answer is how I came to contact the Community.

And, if the fsck action is absolutely necessary: what is
possibly failing because of that?

Thanks again for your interest.

Best,

I can’t answer your question re RNGD.

If you are not able to fsck then the only way to be confident of no filesystem errors would be to download the backup file(s) then reinstall.

I’ve the mini ipfire appliance. Is there on a backup file?

The IPFire mini has no hardware rng that is supported by the kernel, so rngd will always fail.
Also the messed output is nomal. The hardware loose some characters on the serial line at init runlevel 3.

This is also normal if no rule use the conntrack deamon.

This is normal after connecting. This is a cleanup code that run’s more than one time but we cannot remove it because this breaks the wireless client.

Normal the system should do this at next reboot. You can also force this by creating a file
touch /forcefsck

That didn’t work

Added the touch /forcefsck
[root@ipfire ~]# touch /forcefsck
[root@ipfire ~]# reboot

/forcefsck found, forcing file system checks as requested.
[ OK ]
Checking file systems…
/dev/sda4: 29996/905760 files (0.1% non-contiguous), 616051/3616923
blocks
/dev/sda1: 565/8192 files (0.7% non-contiguous), 12978/32768
blocks
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters
[ OK ]
Remounting root file system in read-write mode…

Still no joy:
FAT-fs (sda2): Volume was not properly unmounted. Some data may be
corrupt. Plea se run fsck.

I’m not acquainted with the mini-appliance.

You should be able to umount /dev/sda2 from the running system. Then run fsck on it. fsck has limited capability on FAT-fs - accept the default suggestions. Then either remount it or reboot.

[root@ipfire ~]# umount /dev/sda2
umount: /dev/sda2: not mounted

[root@ipfire ~]# fsck /dev/sda2
fsck from util-linux 2.28.2
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters

What is the command to run fsck on sda2?

Usage: fsck.ext4 [-panyrcdfktvDFV] [-b superblock] [-B blocksize]
[-l|-L bad_blocks_file] [-C fd] [-j external_journal]
[-E extended-options] [-z undo_file] device

Emergency help:
-p Automatic repair (no questions)
-n Make no changes to the filesystem
-y Assume “yes” to all questions
-c Check for bad blocks and add them to the badblock list
-f Force checking even if filesystem is marked clean
-v Be verbose
-b superblock Use alternative superblock
-B blocksize Force blocksize when looking for superblock
-j external_journal Set location of the external journal
-l bad_blocks_file Add to badblocks list
-L bad_blocks_file Set badblocks list
-z undo_file Create an undo file

Your command looks OK. fsck might deduce the filesystem type from /etc/fstab, in which case yours is reporting no errors.

Other variants might get more action:

fsck.fat, fsck.vfat, fsck.msdos all do much the same, when run against device /dev/sda2. If any do report errors then probably accept any offer to fix.

Only one return different from previously.

A web search returned about the same:
https://www.tecmint.com/fsck-repair-file-system-errors-in-linux/

root
-bash: root: command not found
[root@ipfire ~]# fsck.fat /dev/sda2
-bash: fsck.fat: command not found
[root@ipfire ~]# fsck.vfat /dev/sda2
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters
[root@ipfire ~]# fsck.vfat /dev/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
open: No such file or directory
[root@ipfire ~]# fsck.vfat /etc/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
*Got 262 bytes instead of 512 at 0 *
[root@ipfire ~]# fsck.msdos
usage: fsck.msdos [-aAflrtvVwy] [-d path -d …] [-u path -u …]
device
-a automatically repair the file system
-A toggle Atari file system format
-d path drop that file
-f salvage unused chains to files
-l list path names
-n no-op, check non-interactively without changing
-p same as -a, for compat with other *fsck
-r interactively repair the file system
-t test for bad clusters
-u path try to undelete that (non-directory) file
-v verbose mode
-V perform a verification pass
-w write changes to disk immediately
-y same as -a, for compat with other *fsck
[root@ipfire ~]# fsck.msdos /etc/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
Got 262 bytes instead of 512 at 0
[root@ipfire ~]# fsck.msdos /dev/sda2
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters
[root@ipfire ~]#

you will find all fsck* binaries in /sbin/

Only one return different from previously.

A web search returned about the same:
https://www.tecmint.com/fsck-repair-file-system-errors-in-linux/

Trying to Clean System Report Kernel:

compat_xtables: loading out-of-tree module taints kernel.
FAT-fs (sda2): Volume was not properly unmounted. Some data may be corrupt. Plea se run fsck.

root
-bash: root: command not found
[root@ipfire ~]# fsck.fat /dev/sda2
-bash: fsck.fat: command not found
[root@ipfire ~]# fsck.vfat /dev/sda2
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters
[root@ipfire ~]# fsck.vfat /dev/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
open: No such file or directory
[root@ipfire ~]# fsck.vfat /etc/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
**Got 262 bytes instead of 512 at 0 **
[root@ipfire ~]# fsck.msdos
usage: fsck.msdos [-aAflrtvVwy] [-d path -d …] [-u path -u …]
device
-a automatically repair the file system
-A toggle Atari file system format
-d path drop that file
-f salvage unused chains to files
-l list path names
-n no-op, check non-interactively without changing
-p same as -a, for compat with other *fsck
-r interactively repair the file system
-t test for bad clusters
-u path try to undelete that (non-directory) file
-v verbose mode
-V perform a verification pass
-w write changes to disk immediately
-y same as -a, for compat with other *fsck
[root@ipfire ~]# fsck.msdos /etc/fstab
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
Got 262 bytes instead of 512 at 0
[root@ipfire ~]# fsck.msdos /dev/sda2
dosfsck 3.0.9, 31 Jan 2010, FAT32, LFN
/dev/sda2: 5 files, 121/16343 clusters
[root@ipfire ~]#

The fat partition is only used on efi systems. Remove it from fstab and ignore it.
Looks like fsck.vfat cannot fix the fs. I run sometimes in this error on linux systems.

The problem in the first place wasn’t the possibility
the sda3 was corrupt, it is about the Random Number Generator Daemon
not working.

Any idea how to start that?

Do you get a graph in Status>Entropy? my rnd is stopped but I get about 3k in Entropy.

Rngd works only if hardware is present. It need a kernel supported hwrng or a cpu with rdrand.

It is normal that it fails on the apu4.

From what I understood Entropy is only from where the RNGN gets it seed, but in its self it is not enough.

My Entropy graph waves up and down, and not much more than 2. I’ve seen graphs where it is 4 and a straight line. And thought it was green when the OS first was installed - that’s why my concern.

Rngd is not the Random Number Generator. It is a deamon to seed the kernel rng from an hwrng if the kernel has low entropy.