OpenVPN error "wrong password" for iPhone iOS

Hi guys, thanks for any help.

For importing the .ovpn file everything is ok, no problem
I can’t import the certificate “file.p12”. because it gives me an incorrect password error.

I use OpenVPN Connect version 3.4.0
ios version 16.7
IPFire 2.27 (x86_64) - Core Update 180
openvpn --version
OpenVPN 2.5.9 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Sep 19 2023
library versions: OpenSSL 3.1.2 1 Aug 2023, LZO 2.10

With win10/11 and android13 no problem.

Thank you all

First try to use a password with strictly only ASCII characters, do even use the ‘_’. If you still have the same problem, we can look on a different direction.

Tried it, nothing to do, same problem.

Yes, this will not work at all. I think it’s because you’re supposed to “export” your keys to a .p12 file using openvpn and the export should have a security password (it’s not the certificate password), because the OpenVPN app on iOS (other systems as well probably) expects the .p12 file to be password protected and this is the password it asks for. The certificate file from IPFire is not password protected this way.

The only way I was able to make my OpenVPN connection to IPFire work on iOS is to download the “insecure client package” (this is only available if your certificate has no password) and import the .ovpn file to iOS (you don’t need the other files, these are all embedded in the .ovpn).

BUT first you have to edit the .ovpn file and comment out the lines

auth-token-user USER
auth-token TOTP

, otherwise the OpenVPN app will refuse to connect. There’s another topic on this forum about this.

Frankly, OpenVPN is a bit of a mess right now when it comes to client configuration. I was recently importing a connection in Fedora and had a lot of headaches with it as well.

1 Like

did you try the steps described in my tutorial? I tested them and at the time they used to work. Using the insecure package is always an option, but importing the certificate in iOS has always worked when I tried.

1 Like

try to follow the steps described in this tutorial. The initial part is the certificate preparation in IPFire, and then there is the client part, both for android and iOS. If you follow the tutorial to the letter and still does not work, I will assist you in troubleshooting.


thx !!

This way works now other options dont work - it´s a boring situation but it works