OpenVPN Connect 3 on Windows 10 - opensslcontext ca not defined error


I’ve setup succesfully OpenVPN on ipfire v168 with Roadwarrior access.
Access from macOS with Tunnelblick works.

However on Windows 10 with the official “OpenVPN Connect 3” client, there’s a connection problem:

I downloaded the openVPN zipped “Client Package”, imported the “.p12” (with password) and the “.openvpn” config files and after trying to connect I get the following error:

Connection Failed - Error message: ssl_context_error: OpenSSLContext: CA not defined. I've also downloaded the root certificate and the host certificate, but not sure if I need that.

Does someone use “OpenVPN Connect 3” on Windows 10 ?
I get the same error with older version OpenVPN Client 2.7.11.

Any help is greatly appreciated!

Try the steps in the following post:

Or install the community version


1 Like

Thank you very much! It works now on Windows 10 by using “OpenVPN Community Client” (v.2.5.7 for me).

The setup is a different but the .p12 file is read from the openvpn config dir.
The OpenVPN Connection is hidden at launch, so I’ve found a good tutorial here:


1 Like