No Internet / Domain Name System "Broken"

Hi Community, i have to come back with a Problem what i had some time ago.
See post below (no Internet because of broken Domain Name System):

Iam facing the same issue again.
But i can not solve it. (vodafone Kabel Modem in Bridge Mode)
This is how it looks:

I tried follow:

  • turn off Vodafone Kabel Modem (2 minutes - 60 minutes)
  • switch from Bridge, to non Bridge and Back with enough time to boot and sync
  • reinstall IPFire to newest version
  • turned off / restarted several times with different sequences IPFire and Vodafone Modem
  • changed the DNS to TCP / TLS
  • changed back to Provider DNS as UDP

After spending a complete day i have no idea anymore how to fix.
Does someone have an idea?


Can you ping the name servers or

Keep TLS, no need for UDP.

Seems like it’s the same problem I had with my VF cable connection → DHCP client on red0 won't reassign IP upon reconnection - #25 by angrytux

I named it and a cronjob checks if red is down. If that’s the case ipfire handles a reconnect. Cronjob: */15 * * * * /root/

It takes a few minutes and all works again, including dns.

1 Like

No, it says unreachable

Your dns servers aren’t correct for dns over tls too. You need an ip and the tls host name.


1 Like

Hi, thanks for the feedback.
Looks like is a VF problem… had this in the past but not so extreme like.
Somehow it always worked after view times

I made it in the console manual:
dhcpcd -k red0
waited 60 sec
dhcpcd -n red0

still not working :frowning:
And i changed back to TLS.

No, thats correct:
example for one of my DNS Servers

If you do the red restart sequence you should get messages on the console and/or in /var/log/messages.
If the ping to the servers isn’t possible, I think there is problem on the IPFire-modem connection or in the modem itself.
Does the modem ( VF router in bridge mode ) signal successful connection to the provider network?

When i connect my laptop and restart the modem i get a DHCP and able to have internet access (bridge mode).
Therefore i beleive the modem is ok.
In the morning i turned the bridge off, everything works fine, too.
But i turned it of course back.

Still same issue

Last step says DNS not functioning, before the OK overrides

Is there any idea from someone?

I think i go back to 173.
How can i find the old versions of ipfire?


Here is CU 173:

Installing this will wipe your drive so make sure you have a backup on a separate hard drive.

1 Like