Domain Name System Status "defekt" Broken

Dear Community,

i have Vodafone Internet.
Yesterday i recevied the new Modem because i changed my contract from 500Mbit to 1000Mbit.
The old modem was running in Bridge Mode.

I changed the Modem and then i changed again in the Interface of Vodafone the Mode to Bridge.

Now my IP-Fire gets the Public IP (its working)

But i dont have any DNS resolve or DNS, therefore internet is not working.

In the Domain Name System i get the Status broken.


I connected my Notebook directly to the Vodafone Modem (Bridge Mode).
Internet works and also i get the DNS from Vodafone.
→ Its not a Problem of the Modem oder Vodafone.


  • I made some restarts
  • chaned to manual DNS
  • changed to Standard DNS of provider
  • TCP / UDP
    Nothing is working.

I attached some Screenshots. I hope someone can help me.


Which errors are displayed if you hover over the ‘Fehler’ word?
Did you try without ISP DNS, but with enabled?

Thanks for the fast answer.
Attached the Pictures, its a timeout for both settings.

I’ve just tested your case. ( It lasts, if you first have to disable 10 servers. :wink: )
If I allow the DNS servers of the ISP ( Vodafone/Unitymedia Cable Internet ) the status is ‘broken’ (sometimes), ‘ok’ otherwise.

Thanks for the Info.
So what steps you recommend?
Or should I make a fresh ipfire installation?


I recommend not to use ISP’s DNS servers, but to use some trusted servers listed in the wiki.
Google and cloudflare I use only for backup.

I have still the same issue.
When I use a non ISP DNS I get still no internet connection and Domain Name is broken.

Any other ideas?

Ok now it works.
The only thing what i did, i restartet again the Modem of Vodafone.
Parallel i deactived the DNS from the ISP and added some more.
After restart of IP-Fire it worked.

I dont know why!?!?!

Yes, that makes sense.
I forgot the modem reset. DOCSIS modems or the CMTS often bind the end point MAC address to the connection. This is released by a reboot for example.

EDIT: Just one more thought about this problem.
‘Broken’ means there is some problem with the nameserver chosen by unbound. So this state may change intermittend to ‘ok’, if a functioning DNS server is chosen.
Hope this is right. Could not really reproduce this error, because I specify ‘nice’ servers.

1 Like