New Install Can't Access Web interface

Hello All,
I’m new to IPfire not some much with linux in general. I can install IPfire without issue but I am unable to access the webinterface. I’ve tried doing it directly through the ethernet to a PC and through my router and I get nothing. Is there a way to access directly through the PC IPfire is installed on?

This is intentionally blocked. You need to work through the steps in:
web_interface
which should be accessible via:
https://{your IPFire green0 address}:444

To say it the other way.
IPFire doesn’t have a Graphical User Interface, but a Web User Interface.
The most direct interface to the OS is the console, implemented either as keyboard/monitor or serial connection ( depending on the HW ).
Console access is also possible using SSH; but this needs basic network functioning, like the WUI ( which depends on a functioning web server also ).

Hi @thelyon

If I understand you correctly you have installed IPFIre on a mchine and you have tried to access the WUI on a PC connected to the Green Ethernet interface.

You say you “get nothing” but there must have been some sort of error message. It would be helpful to know what that message was.

If you tried using the hostname for the URL, have you also tried using the IP address as suggested in the wiki section that @rodneyp provided a link to? Does that connect to the IPFire WUI or do you get the same error message as when using the hostname url?

1 Like

Yes I have tried the host name and IP address. All I get for an error message, if you can call it that, is a boiler plate can not connect page in my web browser. Both host name and IP get the same blank message.
I’ve tested the ethernet ports and both work under using linux mint live usb so I don’t believe it is a hardware issue. During the install IPfire sees them both so I don’t think it is a driver issue either.

Reinstall and try again?.. bad install maybe?

You could do that but I think it is worth doing a bit more investigation first to see if we can find out what the problem is.

Are you able to access other url’s such as ipfire.org or is all web access saying that it cannot connect?

If you can connect with other url’s but not your IPFire installation then check in

/etc/dhcpd/dhcp.conf

to see what has been entered under #GREEN for the IP address on the line option routers
Is this the same IP that you used for trying to access the WUI?

If you cannot connect with any url’s then have a look in

/var/ipfire/dhcpc/dhcpcd-red0.info

and see if you have got a connection with your isp. There should be entries filled out for the broadcast address, dhcp_lease_time, domain_name_servers, ip_address and routers in which case you are connected to your ISP. If the file is empty then you are not connected to your ISP.

If the entries are showing you are connected my next question would be about the status of your dns servers but I am not sure of the best way to test for that from the command line.
Maybe someone else can suggest how to or give hints on what/where else to look at.

EDIT: Jon updated to /etc/dhcpd/dhcp.conf

2 Likes

On ipfire console, commands ip address or ifconfig will show the actual settings of all interfaces.

1 Like

Hello, I am having a similar issue. I am not able to access the web interface, but I am also not able to connect any system to the “Green”/LAN. It appears to me that no systems on the Green side are being assigned an IP address.

I have checked /var/ipfire/dhcpc/dhcpcd-red0.info mentioned above and there are entries. I am also able to ping 8.8.8.8 from the ipfire console. So I am convinced that the “Red” (red0) connection is working properly.

I have no /etc/dhcpd/dhcp.conf at this location mentioned in the edit above.

I am attempting to install IPFire on a Raspberry Pi.

I would welcome any troubleshooting tips for figuring out why I can’t connect a computer to the Green and get an internet connection. Thanks!

Edit:
A: Output of errors from /var/log/messages

Common error lines (sorry, can’t seem to forward from console to any other system)

“[1397:0] error: SERVFAIL <. DNSKEY IN>: exceeded the maximum nameserver nxdomains”

“[1397:0 info: failed to prime trust anchor __ DNSKEY rrset is not secure . DNSKEY IN”

“[1397:0] info: validation failure <. DNSKEY IN>: no signatures from 192.168.XXX.X (NOTE: this is the IP for my Amplifi Router connected to the Red side of my Raspberry Pi. END NOTE) for trust anchor . while building chain of trust”

“[1397:0] info: validation failure <ping.ipfire.org. A IN>: key for validation . is marked invalid”

“ntpupdate error”

“Giving up: There was no chance to get the file 2.27-armv61/lists/server-list.db from any available server. There was an error on the way. Please fix it.”

“MIRROR ERROR: Could not find or download a server list”

Have you configured a valid IP Address and Netmask on green and also configured the DHCP Range inside this Network.

You can reconfigure green IP and networkmask with “setup” and there is also a way to access the WebUi on the IPFire itself to reconfigure the DHCP but it is uncomfortable. Type “elinks” on the console.

3 Likes

I believe I have configured a valid IP Address and Netmask on Green and also configured the DHCP range. Below are the details.

Configuration type: Green + Red
Green IP Address: 192.168.2.1
Green Netmask: 255.255.255.0

For DHCP Settings, I can only find those in regards to Red
I have selected “DHCP”
BUT
My IP adress, Network mask, and Gateway I did not change.
These three are default values of 0.0.0.0. (Possible Problem?)

This are the wrong DHCP settings. (This is the client for the red side)

I think you have just not enabled the DHCP Server in the Installation process. To access the WebUi you have to set a fixed IP in the same Network (192.168.2.2-192.168.2.254) to your client that is connected to the green nic.
After this you should reach the WebUi and enable the dhcp server on green with a matching dhcp range:

Now you should also get a working IP if the Client is set to “Automatic”

3 Likes

Thank you! I will try this this evening and edit this reply.