Mistakenly installed Core 159 Testing

Hello all,
Yesterday I received the message that the Core 159 was released. On my ipfire it was not yet offered and I have test the channel set to testing and saved. Here I was offered the Core 159 and I reset to Stable. Now the Core 159 was still shown and I installed it and also did a reboot. This morning was in the Pakfire still various packages to see which I still updated.

My problem:
It shows me the following on the page of Pakfire “IPFire 2.27 (x86_64) - Core Update 159 Development Build: master/ff54a798”.
Can I now somehow switch to the Core 159 stable or does it work with the Core 160? Where can I see with WinSCP if the correct channel is set, so not on the web interface itself because there is Stable stored.


Hello all,

I have now noticed that the temperature on my router since the upgrade to Core 159 in the testing variant has made an immense leap from 50 to over 80 degrees. Unfortunately, I have not yet received any information about whether and how I can switch to the stable version.

I hope that my fanless system does not suffer any damage here.

[root@router ~]# sensors

Adapter: ISA adapter
in0:           432.00 mV (min =  +0.00 V, max =  +1.74 V)
in1:           600.00 mV (min =  +0.00 V, max =  +2.04 V)
in2:             3.39 V  (min =  +0.00 V, max =  +4.08 V)
in3:             3.38 V  (min =  +0.00 V, max =  +4.08 V)
in4:             1.04 V  (min =  +0.00 V, max =  +2.04 V)
in5:             1.70 V  (min =  +0.00 V, max =  +2.04 V)
in6:             1.69 V  (min =  +0.00 V, max =  +2.04 V)
in7:             2.99 V  (min =  +0.00 V, max =  +4.08 V)
in8:             1.92 V  (min =  +0.00 V, max =  +4.08 V)
fan1:             0 RPM  (min =    0 RPM)
fan2:             0 RPM  (min =    0 RPM)
fan3:             0 RPM  (min =    0 RPM)
SYSTIN:         +47.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM
                         (crit low = +127.0°C, crit = +127.0°C)  sensor = thermal diode
AUXTIN:         -15.0°C  (high = +80.0°C, hyst = +75.0°C)
                         (crit low = +127.0°C, crit = +127.0°C)  sensor = thermistor
PECI Agent 0:   +41.0°C  (high = +80.0°C, hyst = +75.0°C)
                         (crit low = +127.0°C, crit = +127.0°C)
PCH_CPU_TEMP:    +0.0°C
PCH_MCH_TEMP:    +0.0°C
intrusion0:    ALARM
beep_enable:   disabled

Adapter: ISA adapter
Package id 0:  +43.0°C  (high = +92.0°C, crit = +100.0°C)
Core 0:        +41.0°C  (high = +92.0°C, crit = +100.0°C)
Core 1:        +40.0°C  (high = +92.0°C, crit = +100.0°C)
Core 2:        +40.0°C  (high = +92.0°C, crit = +100.0°C)
Core 3:        +41.0°C  (high = +92.0°C, crit = +100.0°C)
Core 4:        +40.0°C  (high = +92.0°C, crit = +100.0°C)
Core 5:        +40.0°C  (high = +92.0°C, crit = +100.0°C)
Core 6:        +44.0°C  (high = +92.0°C, crit = +100.0°C)
Core 7:        +40.0°C  (high = +92.0°C, crit = +100.0°C)

Adapter: PCI adapter
Composite:    +42.9°C  (low  = -273.1°C, high = +80.8°C)
                       (crit = +80.8°C)
Sensor 1:     +42.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +47.9°C  (low  = -273.1°C, high = +65261.8°C)

Adapter: PCI adapter
temp1:            N/A

Adapter: Virtual device
temp1:        +87.0°C

What kind of adapter or component is this?

Adapter: Virtual device
temp1:        +87.0°C

Best regards Paul

Just switch back to stable and it will automatically reinstall the latest update from the stable tree, which is again 159.

Regarding the hardware, if that is a correct reading (PCH is the chipset) then this is a horrible hardware design and I would consider that a fire hazard. Turn it off, put a fan in.

However, this only occurs since the Core Update 159 Development Build was installed.
Currently I have already installed Core 159.

The system load has also changed due to the update.

I would back up the config files and reinstall from scratch using a USB key. Then, restore the config files.

Is it already known when the Core 160 will be released?

No, it isn’t even in testing, yet.

Hello Michael,

can you please tell me what’s wrong with my hardware configuration?


Last year I bought a Nimbus from Cirrus7 that has the following equipment.

  1. Intel Core i7-9700T (35W TDP), 2,0GHz - 4,3 OctaCore - HD
  2. ASRock IMB-1213
  3. 32 GB SO-DDR4 2666MHz
  4. Samsung SSD 970 PRO 1TB, M.2
  5. Samsung SSD 860 EVO 500GB,
  6. WLAN Compex WLE600VX
  7. Delock USB-to-LAN Adapter 62121 USB 3.0

I use the QEMU add-in and have 5 VMs in operation but the load is very low.

I have already set to Stable but no update is shown and the system remains on Core 159 Development Build.

to reinstall core159 you have to edit /opt/pakfire/db/core/mine back to 158 and run pakfire upgrade

I am not an expert when it comes to hardware at all, but I do not think that it is generally possible to cool 35W TDP passively.

With 5 VMs, your system would have a lot of load, and I don’t think it was designed for that.

Maybe moving it to a place with some more airflow is a good idea. The case should be hot.

Here is the feedback from the manufacturer.

this is the chipset (Q370) and not the CPU. The CPU has a temperature of 44C on the screenshot.

Firstly, I think that it is not the real temperature, but a bug after an update. See e.g. High PCH temperature reported - Cannonlake/Coffeelake / Kernel & Hardware / Arch Linux Forums. This is also supported by the fact that it is a sudden temperature change and cannot be determined via the case temperature. On the other hand, the Intel chipsets are designed for a temperature of 110-115C. For this reason, the chipset isn’t even cooled directly via the case (so it isn’t directly coupled to the case like the CPU). But only indirectly via the case. That means that the heat is indirectly dissipated via the case due to the rising internal temperature.

I also believe that QEMU was included in the update to Core 159 (Development).
Can I see somewhere which packages were installed last?

You can check the pakfire logs in /opt/pakfire/logs/

I have also less hope that reinstall core159 will change anything because the only change between devel build master/ff54a798 and final core159 is the version string.

the last commit for core159 is ff54a798

Did I see correctly that libvirtd (QEMU) has been updated and that there is nothing in the release notes about Core 159.

What is the official version of libvirtd in the stable release of 159 because I have 6.5.0?

On 18.08. I had tried in the evening to install the Core 159 because yes the mails came to it. Under Pakfire nothing was offered and so I had switched to Testing Version and searched and what found. After that I switched back to Stable and saved it. Now the 159 was still displayed and installed by me but it is probably still the development version.
Since this evening the Temperator is so high and only the next day I saw the other package to update anstanden and here also Libvirtd although of it nowhere the speech was.


core159 is an update for the base system. libvirt is an addon. addons can individual updated between core updates.

current libvirt is “6.5.0-26” (same in master and stable tree)

As i already mentioned: The version from your screenshot and the stable core159 release has no changes except the version string.

I have reinstalled the Core 159 through Pakfire according to Arne’s instructions and unfortunately it remains at the current state. I wanted to read out the temperature using an Ubuntu Live System but there is no suitable package included. In the BIOS I could only see the temperatures of the CPU and M/B which were below 50 degrees.
I could not find the other high temperature anywhere in the BIOS.

Maybe this weekend or next I will take the time to re-set up the router once.

I would then first take the Core 158 without AddOns and see what temperature is displayed there and then update to the Core 159.

Have you tried to install lm-sensors on the life system.

sudo apt install lm-sensors

and then “sensors” should get the data


I had already tried to install lm-sensor on an Ubuntu Live USB stick but it did not work even though it is not write protected. Maybe I missed something but I was able to access the internet.
Still trying to install Linux directly on a USB stick.

I started the router from Ubuntu 21.04 and was able to read the temperatures. The identical temperatures as under ipfire Core 159 are displayed here as well.

Ubuntu 21.04 has the Linux kernel 5.11.0-16.
Ipfire 159 got the kernel 5.10 if I saw it correctly.

Which kernel did ipfire 158 have?
I could now test with an old Linux which has the identical kernel as the Core 158.

Did I see correctly that until Core 158 the kernel Linux 4.14.198 was used (see Core Release 150)?

So I would have to try it with this version here → Ubuntu 18.04.


I have now booted from Ubuntu 17.10 and there the temperature of “pch_cannonlake-virtual-0” is not shown to me at all.

Anyone else have an idea? Is it possible to start ipfire live from the USB stick because I do not want to rebuild my router yet?

If you can boot from the USB, you can install IPFire on a USB stick and boot from it.