Kernel panic on attempted install

I had my first IPFire install on a virtual machine over the weekend. Got to see a lot of it’s abilities and power. But when trying to even get the software to boot on real hardware (APU1) I’ve had nothing but problems. I use Ventoy to “normal” boot the ISO, and panics the kernel, error -8 (/sbin/init exists but can’t be executed). If I use Ventoy to “memdisk” boot the ISO, I get the install menu, but the installer can’t find (error 404). APU PXE booting, my last option today, has the same problem memdisk booting does - fails at the -full .iso download.

I can’t even obtain the -full .iso on another system. Or on another internet-connnected device (at home). I cannot complete this install.

SIGH … time to write this up and notify the best place I can think of…

What is Ventoy? Why don’t you use the standard iso and follow the procedure for the serial console install?

EDIT: I see, Ventoy is a tool to burn the ISO to a USB stick. Never used it, but I can tell you that Balena etcher never failed me.


I have never had a problem using dd from Linux as per the wiki.

1 Like

I confirm that Balena etcher and dd are the only two tools that have never failed in my hands. Anyhing else, is a game of chances.



Can we move the replies away from method of writing to USB? If the APU1 boots at all, it should be working (hence, “normal” vs “memdisk” vs APU1 PXE - all had flaws). I want to call attention to the HTTP error 404 when it tries to obtain the full image to apply to disk. Move forward from method of booting to the actual error on a working boot.

the link I provided in my reply which I re-post here, works perfectly fine from my network. Maybe it is a issue of your particular network? Hopefully, others will check and maybe report here.

If the installer is trying to download the installation file when you are using a iso on a usb source then this is an indication that either the installation media is corrupted or the source is not correctly mounted.

See post 7 in this thread

1 Like


That is, for best I can see, a boot image and not an install. it tries to obtain during install. This file is 404.

Adolf, Helpful link. I’ll use this as new information on my next attempt.

you should burn again the ISO file on the USB disk. This is why we were discussing which program to use for the task.

1 Like

Can you confirm that you are getting this error when you are trying to use PXE booting, when it downloads the installation file from the website.

If yes then the problem might be due to the iso file naming change that occurred early September 2022. A bug was raised and fixed for the iso naming in the backup code to also be updated.
It might be that the download file name structure has not been changed for the PXE boot. I am not positive on this, I will need to look through the code for the PXE booting to see where it gets the file name from.

The link you provided has the old naming structure on it.

The first link is the actual installation iso link currently on the website.
The second link is the one you provided. The file name for the installation iso is still using the old naming structure.

1 Like


Yes, using PXE booting from the APU1 (now ignoring all usb boot medium) failed at this step too.
This matches my experience with this reply. It also provides TON of useful information.

Ventoy USB normal - kernel panic
Ventoy USB memdisk - 404 error
APU1 iPXE - 404 error

Hope that paraphrasing makes it better understanding.

I routinely use Ventoy, mainly for installing openSUSE and EndeavourOS, but did use it once for IPFire x86_64, without any issues.

You might need the latest Ventoy, which has the option to boot to GRUB.

You are putting the ISO, not the IMG.GZ on Ventoy stick ?

Okay, So I have found that the installer program still has the old download url structure so PXE booting won’t work because the installer is expected to get the installation iso but the download url is the incorrect one.
I will raise a patch to correct this and submit it.

Bug has been raised for this.
Bug #13078
Patch has been submitted to the dev mailing list.

However you should still be able to install from a usb that has the iso properly downloaded into it.
If when you try and install from the usb you end up with the same url link being used to try and download the iso this means that the installer could not recognise something in the iso or there was some corruption and so it is trying to download the iso from the IPFire site.

The installer running from an iso on a usb should never need to access the iso file on the download url because everything is in the iso file.
This would suggest a faulty iso copy to the usb or an incorrect mounting of the usb stick on the system.

Two months ago I successfully installed IPFire onto an APU4 using an iso manually downloaded from the download site and copied via dd to a usb stick. I then started the APU4 up and I was able to run the install which never tried to access the iso from the download URL


three weeks ago I installed from scratch 173 an my APU2 using a USB stick without any problem.


It was late, and I was eager to get out of work so I can do my errands for that night - I didn’t send my latest. Although Ventoy works great for everything ELSE I ever put on it, IPFire isn’t happy with it. I formatted a 1GB stick with Rufus (hey, I stick with apps I am already using) and worked an install without issues. Now I need the install to have a RED GREEN BLUE system and finally get embedded wifi in my APU1. the kernel panic concerns me but is purely caused by Ventoy, WHATEVER it’s doing. Glad I found something to help the project.