Kernel Installation Freeze with Indirect Branch Tracking When Using Hypervisor (was: Core177 can't install vs core176(yes))

hello, i am working with ipfire for many years, but now core 177 not working. Here is the details

  1. the installation is freezing as soon as i choose “Install Ipfire” in the menu
  2. the installation is freezing too as soon as i choose “Install Ipfire in text mode” in the menu
    the screen become black with a frozen cursor
    Everything work well with all previous version of ipfire
    my host hardware : 17-13700, 64gbram DDR5, gtx-1080,Intel i350-T4 network card
    my host software : windows server 2022 datacenter, Hyper-V (for all virtual machines)
    ipfire VM config : 6gb ram, 20gb hdd, 2core cpu, 2 nic, Gen2, secure boot disabled
    i tried all 4 previous version with this config and it work perfectly
    Also, yes i did the test with Gen1 mode, and the exact same result

i wonder what is the change in core177 so its not working anymore on my system
any idea ?

Maybe is the indirect branch tracking in combination with the use of an hypervisor.

See the last message of the Arch linux thread linked above, quote:

I was able to boot the installation medium properly by adding “ibt=off” to the kernel parameters (to those wondering, just press e when prompted on where to boot, and then add “ibt=off” at the end of the line starting with “linux”)

1 Like

Awesome sir! yes the “ibt=off” do the job. I can do the install now. :+1:

you probably should open a bug report.

yes i agree. According to documentation, This “Ibt” is supposed to work on Intel Cpu. Mine is I7-13700. Also Maybe core 177 has some problem with combination of intel 13700 and Nvidia.

1 Like