How to use Blue zone as VLAN via Green?

Hi everybody,
I’m running IPFire (core 153) on a APU Board with 3 nics. IPFire is set up as “Green + Red + Orange”.
Now I’d like to connect wlan APs, running OpenWRT which is able for multiple VLANs, to my green network providing 2 SSIDs, one for guest access. To have the guest access separated my idea was to use the blue zone configured as VLAN via the green network.
I’ve thought it would be possible just to change the network type to “Green + Red + Orange + Blue” and set the blue zone as VLAN to the nic assigned to the green network via the WUI. But the blue zone doesn’t show up in the WUI to configure it as VLAN?

Any ideas how to set this up via the WUI, or do I have to configure this via the config files?

Regards
Pete

Hi @pete

Welcome to the IPFire Community.

You can’t have more zones that there are nics.

You can create multiple vlans in a zone but this has to be done with the config files. You can’t do it from the WUI.

@hvacguy has posted on this topic and provided links. Search for his post on vlans.

Hi @bonnietwin

thanks for your reply. I think I have misinterpreted the possibilities of the zone configuration and the following post totally.
https://forum.ipfire.org/viewtopic.php?t=23206#p126650

In the post mentioned above it seems that he has configured the nic for the blue zone virtually.
That would be a convenient approach for me too.

Furthermore I’ve found some threads concerning VLANs which reference to the wiki with the following link https://wiki.ipfire.org/optimization/vlan
Unfortunately this one is dead.

Is there any guide how to set up a virtual nic under IPFire?
Where do I find the How to of the IPFire wiki concerning vlans?

Regards Pete

Hi @pete,

Yes, from that forum post it does suggest that you can set up a zone without a nic assigned.

I just tried following the steps in that forum post with one of my testbed vm IPFire’s and I selected ignore for the orange so leaving it unset without a nic assigned. When I went to the Zone Configuration page in the WUI the orange zone was not present. That seems to also have been the result for the person in that post.
So what is described in that post doesn’t work.

That link was removed in October 2019.

The post where @hvacguy provided the info on multiple vlans per zone is

https://community.ipfire.org/t/two-or-more-green-networks/4124/2

Hi @bonnietwin,
I came across the video with Timo Eissler that helped me a lot to get an idea how to configure the VLANs. Till then I’ve thought it would be possible to configure VLANs via the WUI, but it isn’t.

I followed the instructions from there, did some crossreading through other threads and what should I say, i configured my first vlan on my IPFire using the zone BLUE :+1: :grinning:
Everything on my testing system running as a VM of course :wink:

So far thanks a lot for your support! :+1:

Ok, next step. How to configure a 2nd VLAN servicing the seperated WLAN for guests.

Thanks for the link of the post of @hvacguy .
At a first glance it seems he configured an additonal zone. Would it be possible to configure VLANSs like blue0.1, blue0.2, …?
I’ve found this thread with the same question, but I’ haven’t figured out the solution yet.
https://forum.ipfire.org/viewtopic.php?f=6&t=22931

Regards
Pete

1 Like

Hi @pete,

Well done on your progress with the vlan. Always wise to do any major changes in the config files with a VM clone. That way you can always go back to your starting point without a full re-install.

Yes they are additional zones but linked to the same parent zone and hence NIC. Therefore they are additional VLAN’s on the original parent zone. They can be called what you want as mentioned in @hvacguy thread. Parent is green and the additional zones can be called green1 green2 green3 etc or brown, purple, khaki, or any names.

At least the above is my understanding but I have never done this myself. I only needed single vlan id’s on each of my IPFire interfaces as I have 4 NICs.

Maybe someone else who has created multiple vlan’s per zone interface can provide some input.

I wanted to give the solution of @hvacguy a try but it seems to be outdated.
There’s no script /etc/init.d/network-vlans anymore. I think it has changed to /etc/init.d/network. But it looks quite different, so I don’t dare to edit it without having it fully understood. Therefore I need some advise from somebody who’s sure what to edit?

What would be great is to have a add vlan or zone button in the WUI.
Fill in a few fields press save.
I wish I could code.

I have done this myself.
In setup mode change to 4 zones.
assigned all 3 nics. left vlan zone unassigned.
from WUI add vlan for last zone
Set up DHCP if required.

Hi,
that’s what I tried, but the BLUE zone didn’t show up neither on my virtual machine nor on my IPFire.
However, I configured the BLUE zone and the VLAN via the config files and it works.

I wanted to configure multiple VLANs according to your guide

Unfortunately it seems to be outdated.
Do you have an solution or any hints for a recent system?

Rehards
Pete.

If you have run setup.From console.
And set up for 4 zones and assigned 3 of them and finish setup/reboot.
If all 4 zone do dot show up this is a bug.
They all should show up in WUI.
and then you can add your VLAN from WUI.

@arne_f mentioned on the other thread (https://community.ipfire.org/t/missing-old-wiki-entry/4413
that a bug should be raised for this but no new bug raised yet. Please raise a bug.
See the above other post for how to do this as provided by @jon

:+1: Done
https://bugzilla.ipfire.org/show_bug.cgi?id=12568

Hopefully no important info missing?!

2 Likes

That looks good to me.
If anything more is needed then you will get asked.
As the bug reporter you will get emailed on all updates or changes to the bug.

Has anyone tried this since the update, I would like to do the same…thanks.