Hardware Graphs



I’ve two issues with the hardware graphs:

  1. As you can see, the sensor identifier swaps between two temperature sensors with every reboot. How is that possible?

  1. Lots of hw graphs within a single graphic is not usefull. How do I increase the hight?


At the bottom of the page, you could select only few of them and save. You can rotate among them. Otherwise I think you need to play with RDD tool with your own scripts.

You also could post a request to the devs.
Good place would be bugzilla.ipfire.org.

The problem is that the size of the graph frame isn’t big enough for so many legend lines. RRDTool writes all description lines. The space remaining is used for the graph itself.
This could be solved by a split of the graph into several graphs or by a dynamic frame size.

Thanks for that tip, but IPFire is not a playground. At least not for me.

The problem is that the hight seems to be static. It should increase with every additional dataset because of the rising legend.

Sure, but because it’s not important, it will be fixed/changed in about 5 years. :upside_down_face:

I don’t think that it is changed in 5 years. :wink:
My experience is, that also those ‘cosmetic’ corrections find a willing developper. An example is the integration of help links to the wiki. Nothing necessary, but implemented supported by an engaged discussion in the devel mailing list.

I wonder if maybe the following topic will be helpful:



  1. I noticed that colors change sometime, but no color swaps between the sensors.
  2. I’m running a Duo Box which has a similar problem: the hardware graphs show a lot of rather useless temperature readings coming from an ‘nct6106’ sensor. E.g., temperature reads are -128 °C or 0 °C. Nothing I need or want to see as graphs.


Stop ‘collectd’:
/etc/init.d/collectd stop

Delete - in my case - the directory /var/log/rrd/collectd/localhost/sensors-nct6106-isa-0a10

Edit /etc/sysconfig/lm_sensors and change the line

HWMON_MODULES="coretemp nct6775"



Unload nct6775:

modprobe -r nct6775

Start ‘collectd’:
/etc/init.d/collectd start

I tried to blacklist this module by adding the line blacklist nct6775 in /etc/modprobe.d/blacklist.conf, but this didn’t work.