Fresh install dhcpd no such file or directory

fresh install of ipfire v2.25 141 latest downloaded from the website and for some reason i get this message after a fresh install and cannot get online or access the web gui

chmod:cannot access ’ /var/run/’ : no such file or directory
have tried a few times to reinstall also tried older distros of ipfire just cant work out where im going wrong
thanks in advanced i am a bit of a network moron so might need it dumbed down a little bit :sweat_smile:

What do your Ethernet interfaces say. Are they both, RED and GREEN up and connected? In your screenshot I see at least one problem with RTINETLINK.

hi i can get the red link up bot green dosent issue any ip address and i cannot get online on the computer or any wired or wireless kit but it seem to talk to the modem- router ok just wont issue any ip address on the green side have also tried a fresh install of ipfire and tried older distros

There is some problem with the DHCP server.
Can you look at /var/log/messages or /var/log/bootlog?

tried that got this

The logs can be read by less /var/log/messages , for example.

BTW, how did you configure your green network?

all i get when i try to bring up the logs is no such file or directory

also red is set up as dhcp instead of static

and green is setup as

internal ip for web gui
start address
end address

if that helps at all is there anything i can type to reset it or something not really sure about how ipfire console works

The address for IPFire green should be ok, if your green network is defined as
But the start and end address are wrong! They belong to your red network

ok what would you be putting for the ip address start-end i have also been using those ip address for a while with an old install with no issues i think

Depends on your network config.
Post the output of ifconfig, please.

sorry not happy about releasing that kind of information as it contains private ip address

unless you want only certain info i can post that

Did you set up your clients IP to a static that fits the subnet of the green interface to check out if you can access the webui?

no i haven’t but i cant even get an ip address from green or even a net connection but ipfire can get time on boot which tells me it has one from the router - modem

Who cares. that’s because your DHCP is not working. You don’t need DHCP if you run a static IP for your clients.

1 Like

ok how would i go about doing this fresh install or commands ?

??? I’m talking about a client that is supposed to talk with the firewall, not the system running the firewall. It’s all about to get access to the webui.

i understand that just not sure on how to achieve that because im a bit of a networking - ipfire noob :sweat_smile:

Yes, this are private IPs ( not accessible and routable from outside ).
To help you, we should know just the network definitions of your system.

From your screen shot in your first post we know RED is
How is GREEN configured?

As an example, my config is
RED : <public ISP network>/22, public IP assigned by DHCP
DHCP pools are chosen as subset of the GREEN and BLUE networks.

ok looks like im doing something during the install perhaps not sure because ive set up ipfire this way before without any issues

i must be missing something really obvious

I aggree with bbitsch: post the green + red (and blue if used) config here (which you set up during the setup routine. You may have done mistakes that were not catched by the setup routine.