Error in RRD::graph for firewallhits

Today after IPFire 2.27 (x86_64) - Core Update 166
firewall hits is like image shown.
how can i repair this?
Kind regards

I would try to follow the suggestions for fixing the graphs when changing to new hardware.

Before deleting any of the rrd graphs is ipt_bytes-DROP_HOSTILE.rrd present in the directory

If yes then it probably means that the data in that graph file has become corrupted somehow.
If the file is missing then something has gone wrong with it’s creation.

In my directory there are two files
ipt_bytes-DROP_HOSTILE.rrd and ipt_packets-DROP_HOSTILE.rrd

Quick check indicates that if file is not present then you get the message “No such file or Directory” so I would suggest that the file has likely become corrupted.

1 Like

I just tried rebooting my system and all the rrd graph files for other iptable-filter-xxxxx directories had the date and time of the reboot but my iptable-filter-HOSTILE has the files still with a date/time of when I did my Core Update 165 so it looks like there is a bug with the update of the HOSTILE element of the graphs. In my case the file is recognised and used but there is no updated data in it.

I will raise this as a bug.

Bug raised


Obviously there was a change in the firewall chains. Therefore collectd didn’t find new data to include in the specific RRD.
See my comment in bugzilla.

Sorry for late reply,
i followed the suggestions in the page,
but with no result.
Kind regards

Did you look at bugzilla #12838?

1 Like

tried everything but still no result.

tried repair script and it worked!!!
Many thanks!!!

User tempo

1 Like

Thanks for the feedback.