DHCP server access during 'setup'

I cannot find how to open the “DHCP server configuration” page as shown on the web page

Can anyone point me in the right direction? I can run setup and inspect/alter any of the current settings.

@bri_n Hi Brian a few questions if I may:
1: How many Network interfaces do you have in your setup?
2: Did IPFire correctly detect all your network interfaces?

Please provide answers to the above then we can go further with assisting you.

Hi Mark

I have a 1Gb port on the motherboard plus a network card with four 1Gb ports
I will use 4 of these 5 ports to set up Red, Green, Orange and Blue interfaces.
All 5 ports show during setup. I chose to put Red on the motherboard port (so no confusion as to which port is Red).
The 4 other ports have mac addresses in sequence.

Kind regards

After setup is complete.
You can access the WUI
To change your DHCP settings.
Note orange has no DHCP.
If you want to change ip address or subnet
You will have to run setup from console.

1 Like

@bri_n OK, fair enough, then when you run the setup and set your IP addresses to the other 3 ports ( assuming that is how it is done, as I only have two, green and red), then when you select the RED interface to reconfigure and select OK, what screen do you get? You should then immediately get the DHCP setup screen. Can you share a screenshot of what you get, please?

1 Like

Hi Shaun

I agree that I can use the WebGUI to change the DHCP settings.
BUT that is not the issue I am raising.
What I want to know is “How do I get to the ‘DHCP Server Configuration’ screen shown on the https://www.ipfire.org/docs/installation/step5 page?”
I see from the Community that Mark has suggested that this page should come up after completing the RED interface. I do not see this page, so my problem must be something else.

Although I have been able to communicate on Green using the WebGUI, I have not yet been able to ping anything (e.g. ping on the IPFire box.

Thanks for the reply, I will potter on.

Kind regards


As I said above run “setup” from console.
Then change nic settings. green and blue etc…

Activation of DHCP, from the setup menu, is available only during installation. Starting setup from CLI after that does not make the DHCP option available.

Simplest solution is to backup whatever settings you already have, then do a fresh install, followed by restoration from backup.

1 Like

Thanks Rodney - that makes sense. I have nothing done post setup, so redoing it is not a problem.

@rodneyp I have to disagree with you, sir. You can always access any part of the setup from the command line, even after installation, by either connecting a monitor and keyboard and re-running the setup command, or by SSH.


@markadewet , this isn’t true.
As Rodney stated, the basic DHCP config is only possible when setup is run in the installation process. You can check this in the sources of setup.
BTW: this behaviour is well documented in the cited wiki page (last paragraph).

@bbitsch No, sir, it IS true, please see attached screenshot of my IPFire SSH login taken a few minutes ago:

Having said that, I am starting to SUSPECT or THINK perhaps that @bri_n MAY be actually looking to configure DHCP for the GREEN interface, which I totally agree is only available AFTER installation, via the WUI.


The topic is “DHCP server access during setup”. Your screen shot shows the possibility to run a DHCP client on the red interface.
The server dhcpd works on the internal interfaces green and blue.

1 Like

@bbitsch As I said, BELOW the image:
“Having said that, I am starting to SUSPECT or THINK perhaps that @bri_n MAY be actually looking to configure DHCP SERVER for the GREEN interface, which I totally agree is only available AFTER installation, via the WUI.”


You are correct this step appears to no longer exist.
When I ran setup. The wiki needs up dated or the the installer has had this step removed?

I checked the wiki and it is correct.

And the installer has not changed (not that I found)

I am not sure what the OP wanted to change, but maybe this might help.

1 Like

When I ran setup from ssh .
I could not locate this page.

The page appears on the initial installation and not with setup.

That explains it.
Thank you

1 Like

My first thought is setup the “Domain Name System” page in the WUI.
Make sure you have a working DNS.

1 Like