Changing Green, Blue NIC IP addresses

Hi, simple question that I cannot seem to find an answer for by searching. During initial setup, I chose IP addresses for green and blue NICs such that they would not overlap with my existing internal network setup. This way, I could test the interface without having to worry about overlapping dhcp assignments. However, now I’d actually like to use IPFire as my gateway, and I cannot figure out how to change the IP address assignments for eth1…ethn. I am used to the networking layout of Ubuntu/Debian systems, and for the life of me can’t find these settings either in the UI or in /etc/. :confused: Do I need to re-install from scratch to change IP addresses? That seems extreme! Please let me know how I can proceed. Thanks much!

Hello crw! Welcome to the IPFire Community!

go to Terminal and SSH into the IPFire box. At the command prompt enter setup:

look for Address Settings.

2 Likes

Thank you! I ran setup, changed the IP addresses, and now things are working as expected. I did have to manually re-write the dhcpd.conf file with the new IP address range, but that was pretty easy. I’ve plugged in my IPFire box and it is working great. Thanks!

1 Like

All,
I am attempting to do the same thing, ie change the green IP addresses from a temporary range back to 192.168.1.1, but seem to miss the point of the solution mentioned here as I keep getting back to the temporary range (happens to be 192.168.20.1)

My procedure is to login as root using a serial connection with Putty. Then change the Green IP address in “Setup” from .20.1 to .1.1 - so far so good. However from this point onwards I am stuck.

  1. Using “Setup” there is no way to change the minimum and maximum IP’s for green. They remain at the temporary 192.168.20.min and 192.168.20.max addresses. This then prevents WUI connections, blocking the use of the WUI to change the min max ranges. perspective.
  2. When changing the min / max ranges in /var/ipfire/dhcp/dhcpd.conf the changes seem to have no effect when restarting the dhcp nor when rebooting ipfire. The IP min max ranges stay the way they are (i.e. 192.168.20.min and.max).
    Need help.

Need and Appreciate help. :slight_smile:

suggestion: you may have to delete the green nic and then re-assign the mac to green, hopefully setup will ask you all the questions.

setup asks for IP address and mask for the interface.
That should be enough:

  • The interface of IPFire MUST be part of the network to be defined.
  • So the equation <network address> = <IP> & <network mask> is true.

For your use cases is valid
192.168.20.1, 255.255.255.0 defines 192.168.20.0/24 as green net;
192.168.1.1, 255.255.255.0 defines 192.168.1.0/24 as green net

By definition the two nets have these properties:
192.168.20.0/24 … net address .20.0, broadcast address .20.255, clients .20.1 - .20.254
192.168.01.0/24 … net address .01.0, broadcast address .01.255, clients .01.1 - .01.254

I finally managed to get things right.

What it took was to connect by serial cable and change all incidences of “192.168.20.” to “192.168.1.” in the following files:
/var/ipfire/ethernet/ settings
/var/ipfire/guardian/ guardian.ignore
/var/ipfire/guardian/ ignored
/var/ipfire/proxy/advanced/acls/src_subnets.acl
/var/ipfire/proxy/squid.conf
/var/ipfire/urlfilter/squidGuard.conf
/var/ipfire/ovpn/ccdroute2
/var/ipfire/ovpn/ccd/‘Bernard L Mol’
/var/ipfire/langs/en.pl
de.pl
it.pl
nl.pl
tr.pl

Then rebooted and all has worked since.

Rgds, Bernard :smiley: