Dell Wyse Z90D7 - Won't boot after update

Hi all,

Quite a long time ago, I tried to update to V2.21 Core Update 122 using PakFire, but after doing so my system wouldn’t boot (wouldn’t get passed BIOS). I ended up reinstalling 2.19 Core Update 120 and everything worked again. I couldn’t post any logs, because it wouldn’t boot to generate any.

A lot of time has passed, and I am worried that I have a system that is well out of date and I am keen to install the latest version of IPFire.

I have a Dell Wyse Z90D7 system ( … 17l/specs/)

I have 3 questions, which I hope someone could help with:

  1. Does anyone know what might have been causing this problem (I think it was a kernel issue, but I am not sure if this is fixable)

  2. Will the latest version of IPFire have resolved this problem?

  3. If I use PakFire to do the update, will it install the very latest version, or will it initially install the update to Core Update 122 and have the same issue. If so, what is the best way to upgrade and maintain my config (which is just perfect for me and I can’t remember all the steps I took to create it).

Thanks all

Just a thought but have you checked to see if there’s a firmware/bios update for your computer? You might diddle with the uefi & virtualization settings in your bios if there are any. I see it has windows embedded so even if your install wiped windows there could be some remnant that uefi is messing around with. I’m interested in thin clients, chrome boxes and other low cost, low power solutions myself so will be interested in what you find.

Thanks @domhnall

I have found this resource helpful for thin clients:

I haven’t tried to update the BIOS yet, because I didn’t want to risk breaking the system, but I might have a go this weekend. I may even consider doing a trial install of the latest version of IPFire on a second hard drive, if I can find one.

In case this helps anyone. I thought I would share my journey of discovery. :slight_smile:

I haven’t been able to update the BIOS, because in order to do it, you either need to flash the chip, or download some massive files and do a complete reinstall of windows on the device. I will do this if I have to for any reason in the future, but not for now.

I have decided to connect an old 2.5" laptop hard drive to the Wyse, as a test HDD for installing the latest version of IPFire. So far, it has installed and configured and boots just fine.

I am now going to put it back into action, and see if it allows me to add my system backup.

If this works, then I will revert to the mini SSD, and try to do a Pakfire update without it crashing. If it does crash, then at least I know I can quickly reconfigure.

Wish me luck!

Awesome. So is that link. That guy has a ton of info on thin clients! :smile:

So, I decided to bite the bullet and use Pakfire to update my original installation.

Unfortunately, it didn’t work and I ended up needing to do a fresh install. The backup then blocked a load of traffic and so I am starting my config from scratch.

So, on a plus point, I have answered my questions :smiley: and the latest version if IPFire works with my Dell Zyse Z90D7.

I have also managed to work out the wiring to connect power to a second laptop HDD, so I may play with turning the system into a music server on top of the IPFire install.

All I need do now, is work out how to configure everything again :frowning:

It is a journey. :slight_smile: Was the pakfire updating an entire new version of ipfire or just the modules? Did it overwrite your configs or did you backup & restore your configs and that didnt work?

I am not sure to be honest. I ran a bunch of Pakfire updates back to back, and after the 10th or so (maybe at about Core Update 134 ish), it all froze and a reboot failed. So I started from scratch.

I had backed-up my settings, but I think the changes in system were such a big jump, that the new version wasn’t all that happy and blocked all traffic.

It all seems set back up now, and is running in a fairly stable config. So I am happy.

Glad you’re back up and running. :+1: :+1: :+1: