Dell Wyse Z90D7 - Won't boot after core update 148 ->150

Hi there,

I previously had issues with updating ipFire (Dell Wyse Z90D7 - Won't boot after update), but managed to resolve the problem.

However, I have just upgraded to Core Update 150 and I am now failing at boot, with the following message on the screen:

Grub Rescue
Error: symbol ‘grub file filters’ not found

Can anyone give me any pointers how I might best recover my ipfire installation (which was setup just perfectly for me…

Thanks in advance

Actually - I have just seen this: GRUB error on 149 upgrade

I shall try the instructions on here and report back.

Sadly, none of that worked.

Any ideas would be much appreciated. I am keen not to do a reinstall if I can avoid it.

Thanks again

Update - I have managed to do a bios update to bring it to the latest standard (it was very old), but it still has the same issue.

I have tried to install a new version of Core 150 to another disc, and it worked, so I am hoping it is just a corrupted grub and the bios update has resolved the original problem.

Any ideas how to fix the grub on the original install?

OK. Hopefully this will help others who are experiencing the same problem and don’t want to do a fresh install.

Having update my BIOS, I then followed this guide to repairing grub using an Ubuntu live CD and “boot-repair”:

The original SSD now boots successfully.

I don’t know if the BIOS was part of the problem, or the update process from Pakfire, but at least I am up and running again!

1 Like