DDNS-updates every 15 minutes

Hello, since yesterday ipfire tries to update the DynDNS every 15 minutes. I’m using ddnss.de and there is a limit of 60 updates a day. The logfile says:

Further updates will be withheld until 2022-09-23 12:00:00.270809
DDNSUpdateError: The update could not be performed
Last failure message:
An update has not been performed because earlier updates failed for sxxxxxxw.dd nss.de

I have had this problem in 2020, but the solution doesn’t work anymore.

Can you please help me? Thank you

From my understanding infra-host-ttl is set to 900 sec (15 min.). Possibly this is the parameter of unbound I would try to change if I were in your place. This shell line should create a file inside unbound/local.d/, which will be incorporated in unbound.conf, with the syntax described by the documentation. However, you should not copy and paste anything you do not understand.

Also, I do not know what I am doing. So, you are warned.

echo -e "server:\n\tinfra-host-ttl: 1440" > /etc/unbound/local.d/increase_ttl.conf

Maybe this is the same error as mine, I have simultaneous unbound errors, that’s why it keeps making ddns updates?

Hello cfusco, thank you, I tried it. Tomorrow morning, after the renew of the ip-adress, I will know, if it is working.

It will not work. My stupid brain did not register that you were talking about dynamic DNS (which was in the title). My suggestion has nothing to do with that subsystem of IPFire. Just ignore it. Sorry about that. You should probably open a bug report, similar to this one: 12328 – www.ddnss.de provider unhandled exception

1 Like

Oh, thank you, I will delete the new file.

Now I have no entry in the logfile at ddnss.de. Ipfire logfile says at 0.00:

00:05:00 ddns[2368]: An update has not been performed because earlier updates failed for xxxxxx.dd nss.de
00:00:00 ddns[2151]: Further updates will be withheld until 2022-09-26 04:50:35.733914
00:00:00 ddns[2151]: DDNSUpdateError: The update could not be performed

Definitely you should open a bug report. Here the instructions. You could use as a model the bug report I linked above.

Hi @jadokus.

Have you tried via command line to perform a forced synchronization?.

ddns -d update-all --force

Sometimes this forces it and fixes the problem. If not, you will see the result.

Tell us something.

Greetings.

2 Likes

Thank you Roberto, my updates for this day are used up, so I got an error. I have deactivated the DDNS an will try it tomorrow again.

Hello Roberto, the synchronization worked. It worked the whole day, but the number of free ddns-updates is going down and down. The logfiles of the ipfire and ddnss.de doesn’t show any update after 09:10. I really don’t know, whats going on and hope, that it is still working after the ip-restart. Thanks so far.

Hi @jadokus.

It occurs to me (I imagine it would work) that the easiest way to lower the number of requests would be to create a file in /etc/fcron.daily/ with the following command, giving it execution permissions and deactivating ddns so that it does not run.

I would do it once a day. If you want 24 times, in fcron.hourly.

I don’t know if I explain myself. Either this (which is perhaps not very pretty) or modify the configuration file (as you have been told in a post above) to adapt the time between executions.

Greetings.