DDNS enabled automatically after being disabled

DDNS is being enabled automatically even though the enabled checkbox is de-selected in ddns.cgi.

Also fcron is running “/var/ipfire/red/active” ] && /usr/bin/ddns update-all every 5 minutes.

/var/ipfire/ddns/settings only contains:
BEHINDROUTER=RED_IP

IPFire 2.27 (x86_64) - Core Update 167 Development Build: master/c22d834

Rob

Can you update to CU 169 to check if this issue still appears?

1 Like

OK, Pakfire upgraded to CU 170. - Still the same.
Try disabling DDNS by unticking the enable tick box on your ddns.cgi and ‘save’
Then reload ddns.cgi. On my systems the enable checkbox is now ticked.

Rob

Hi Jon,

Also CU 170 seems to have re-written fcrontab because ddns is again updating every 5 minutes.

Rob

I was hoping to get you away from the Test build (e.g. CU 167) and on a Stable build with CU 169. You are now on a Unstable build (e.g. CU 170).

What are you seeing that states the DDNS is being updated? Can you post a screen shot of a log?

1 Like

Hi Jon, This is my development box running testing, I was a bit surprised myself though that Pakfire upgraded to CU170 as only 169 was shown to be available when I upgraded.

Not a lot to see in the logs. /var/log/messages has:
Aug 13 21:55:00 ipfire-dev2 fcron[5152]: Job ‘[ -f “/var/ipfire/red/active” ] && /usr/bin/ddns update-all’ started for user root (pid 5153)
Aug 13 21:55:00 ipfire-dev2 fcron[5152]: Job ‘[ -f “/var/ipfire/red/active” ] && /usr/bin/ddns update-all’ completed
every 5 minutes and presumably coming from the fcron entry.

Rob

Do you have multiple DDNS services.
Are they all disabled.
Are they Disabled?
Are there none on your Current list.
Did you hit save button?
Pehaps a WUI button function problem
Will Disable mine and test.

1 Like

Excellent!

I am fairly sure that job will always run. What do you see in the System logs under DDNS?

1 Like

I don’t use DDNS it is fully disabled (or should be!)

DDNS System logs don’t show any entries.

The only erroneous indication I can see is that I cannot turn off DDNS in ddns.cgi

Rob

Can you post that pic? (redact what is needed)

My bad! :pensive: I should have been more specific!

Can you send a pic of the ddns.cgi page?

I think it is much safer, just to start the ddns updater every 5 minutes independant from the enabling/disabling.
The updater itself only sends requests for enabled providers.

This is also deductible from the fact, that the DDNS page doesn’t have a global enable/disable button.
Any manipulation of the fcron tabs bears some possibility for errors.

EDIT: I just tried on my system.
With all providers disabled /usr/bin/ddns update-all --force doesn’t log any activity, so ddns is effectively inactive.
Enabling one provider produces only the log entry for this provider.

3 Likes

If this the whole contents of the ddns.cgi page, you have no providers defined.
See my post above.

1 Like

Rob - Everything is working OK on your system. Nothing DDNS is enabled.

You would see this bottom section Current Hosts if it was:

1 Like

Jon, thanks for looking into this. Try disabling the ‘Enabled’ check box and then reload the cgi. On my system the check box is again set.

Rob, do you mean the ‘Enabled’ checkbox in the ‘Add a host’ section?
This the default value for a new host.
The enabled/disabled check boxes for the defined hosts are in the next section ‘Current hosts’.

I just brought up my test system with a recent CU 169 update and it has DDNS enabled also.

And there are no entries in the System Log under DDNS.



Unless you are experimenting you may want to turn off the debug for fcron. I am guessing you are seeing LOTS of messages that begin with

Jun 15 17:20:00 ipfire fcron[1234]: Job '

Thank you for the clarification Bernhard. Maybe I have misunderstood the function of the enable check box which I thought was to Enable/Disable DDNS functionality. Perhaps the GUI could be clearer and have a Global Enable setting similar to many of the other cgi pages.

Regarding the fcron entries, I have a few of my own programs running from fcron and I like to keep an eye on them. Unfortunately after the upgrade to CU170 I’ll have to add them back.

Rob