CU 186 testing: AX88179 USB LAN adapter not supported?

Hi all,

it seems the AX88179 LAN adapter is not supported in Core Update 2.29 186. I tried 2 upgrades on 2 different machines and a fresh install all ending with the adapter being recognized (lsusb shows it) but networking doesn’t work. Seaching the internet, it seems Unix Kernel 6 doesn’t include support anymore.

Is there a way to add support back in before releasing or do we need to buy new USB LAN adapters? I believe the ASIX adapters are quite frequently used.



From googling around, it seems to be a kernel bug which is being fixed -217204 – ASIX AX88179 does not work in 6.X kernel - and a Debian/Proxmox thread - AX88179 USB Ethernet Fail to Up on Kernel 6.5.13-5-pve, Possible Fix in RC Kernel | Proxmox Support Forum.

1 Like

Wonderful. The next question: will ipfire 186 includes this fix before it gets released?

Please open a bug report. This will help make sure the Development team reviews this information.

Information to add a bug report in IPFire Bugzilla:


There is another patch for ax88179 in Linux v6.6.32

1 Like

I see this in the IPFire queue on May 19: kernel: update to 6.6.31;a=commit;h=25b6a76646691f91f6f267792700dde6adcfc91b

So hopefully @arne_f will have 6.6.32 sometime soon.


I have updated to 6.6.32, please test if this helps.


To get this via pakfire update / upgrade, I assume a new nightly build of master would be needed. Is that correct?
And of course the value of /opt/pakfire/db/core/mine would need to be reset to 185 prior to doing the upgrade.

The nightly build has already been run about 15 hours ago, so you can test it out now.

Correct, you would need to do that to get it to do the latest 186 version from the nightly.

1 Like

@pkuehn are you able to verify if the latest build of CU 186 Testing fixes the problem?

Hi Charles, earliest end of next week. Travelling. Thanks Peter

Gesendet von Outlook für Android

1 Like

Just tried out what I believe is the latest build:
IPFire version IPFire 2.29 (x86_64) - core186 Development Build: master/03de90cc
Pakfire version 2.29.1-x86_64
Kernel version Linux 6.6.32-ipfire #1 SMP PREEMPT_DYNAMIC Tue May 28 00:06:33 GMT 2024 x86_64
But alas still no connection on my AX88179 USB LAN adapters for Red and Orange.
Looked in my box of “abandoned hardware” and found two Realtek RTL8153 based adapters. First tried one on Red and it went online. Then tried the second on Orange and it also went online.
Best regards
Willy Sejr

Something really weird here. I did fresh install of CU 186 Latest and it would not work. Reinstalled CU 185 to verify that the device was all good … and it worked fine. I then did an upgrade to testing. It continued to work. Did several re-boots and it continued working.

Note: this work/not-work is about the ax88179 part on red0

@cbrown - Open any IPFire WebGUI page and cut & paste (or do a screen shot) of the bottom left corner.

For example mine is:
IPFire 2.29 (x86_64) - Core-Update 185

Ugh, I must have been on drugs last night. It is non-functional on …
IPFire 2.29 (x86_64) - Core-Update 186 Development Build: master/03de90cc

Note: Was working fine with IPFire 2.29 (x86_64) - Core-Update 185

Note2: It was happy with kernel from Linux 6.6.15 (or whatever kernel is in CU 185)

Note3: Created bug report 13692

1 Like

I guess I wasn’t completely drugged :slightly_smiling_face: From Linux Kernel Bug 217204

If the HW is booted with good kernel and then rebooted (without losing power) to bad kernel, it will still work. Only if it is booted with bad kernel from cold state (total no power) then it will not work

Thank you for adding the bug report!

CU 185 is 6.6.15

[root@ipfire ~] # uname -a
Linux ipfire.localdomain 6.6.15-ipfire #1 SMP PREEMPT_DYNAMIC Fri Feb  9 19:15:59 GMT 2024 x86_64 AMD GX-412TC SOC AuthenticAMD GNU/Linux

[root@ipfire ~] # uname -r 

Thank you for creation of the bug report. Most appreciated…
Because the AX88179 problem is still there.
The issue is the faullty AX88179 support is independent of using such device on IPfire Red, Orange or Green
My IPfires runs - for some years - of an Asus “MiniPC”.
It has the advance of easy HDD/SDD swap.
I’ve have 2-3 SSD-disks in store for the purpose and with my disk duplicator hardware I might be able to create back ups for new trials (when given time and opportunity).
I’ve tried it out I can now see that the Core-Update 186 Development Build: master/03de90cc did not provide a working solution.
Note: A similar AX88179 problem occurred around an earlier upgrade - V170/171 as I recall.

I have borrowed a ax88179 dongle (usb id 0b95:1790, driver cdc_ncm) which works at my tests without problems even with kernel 6.6.31.

So i fear that there are different hardware revisions out.

Update: I have found a second adapter with the same id but it uses asix88178 module. With this i can reproduce the problem. It will not come up after the first “ifconfig up” but if you set the device down and up again it works.

I will investigate this …

1 Like

this sounds similar to this issue: