Core update 170 - Internet Problems

unfortunately I am also one of the sufferers where the core update 170 has more or less shut down my internet connection.
I am using a Raspberry Pi 4 with a USB Ethernet Interface on
The internet connection runs for about 3-4 hours. Then the connection breaks down. And I have to reboot the IPFire again.
Annoying undertaking:

Under /var/log/Messages I find this:
Sep 26 18:13:05 ipfire dhcpcd.exe[21108]: red0 has been brought down (STOP)
Sep 26 18:13:21 ipfire dhcpcd[1675]: red0: waiting for carrier
Sep 26 18:13:24 ipfire kernel: ax88179_178a 2-1:1.0 red0: ax88179 - Link status is: 1
Sep 26 18:13:24 ipfire dhcpcd[1675]: red0: carrier acquired

Is there already a workaround or wait for update 171?

I fear, you must wait for CU 171 with the new kernel containing the modified driver.
As far as I know, there is no easy workaround besides using the test release or downgrading to CU169.
See also ASIX ax88179_178a USB-to-LAN adapter unusable after Core Update 170

Thank you very much, I see you already have experience with this topic. Strangely enough, a restore to a last version does not work for me anymore. So I have to wait for the next version and hope…

I don’t have experience, but read the community posts. :wink:


The other thing you can try is remove the ax88179 USB-to-Ethernet adapter and replace it with a non-ax88179 adapter. Hopefully you have an extra adapter…

1 Like

What alternative of a USB adapter do I have?
I would buy a new one today.
Would this one come into question?
Realtek RTL8153

Or are there any other alternatives?
Thanks and greetings

I have a USB3 to Realtek RT8153 and it is working with Core 170. I use it as green0, so that the internal NIC is red0 and more reliably found at boot time.


Thank you very much. :grinning: I have ordered one… and I pray it works …

When you say, “does not work for you anymore” what happened?

thank you for asking.
Simply speaking, when I select the iso and then press the restore button, nothing happens. It jumps back to the main menu. Strange??

That sounds like you are using the browse button in the Restore section of the backup page to select the iso and then pressing restore. If that is what you are doing then it does not work that way.

You need to download your backup file from the WUI backup page and save it on the computer you are using for the WUI Web Access. Choose the file with the date/time from before you did the CU170 upgrade.

Then you need to do a fresh install of IPFire Core Update 169 and after doing the setup and rebooting go to the WUI backup page. Use the browse button to go and select the backup file that you saved previously.
Then press the restore icon and your configuration and settings files will all be restored into the fresh install. That will take you back to the CU169 status you had before doing the CU170 upgrade.


First of all, sorry for the late feedback.
Thanks for the detailed information, I will definitely take it to heart.
Just in the second I connected my new Realtek USB adapter and assigned with “Setup”.
Worked and worked very well in the first step.
I will observe whether this now runs better with the new adapter. Will report again.
Many greetings


…short status.
The Realtek USB adapter runs very stable until now.
No connection interruptions have been recorded so far.
Many greetings


I have my raspberry pi 4 working. There is a hiccup when doing the fimrware update. But I did a command base to update. I just use command:-

pakfire update
pakfire install firmware-update

and restart again

try again with pakfire update.

Then do a restart.

Go to the ipfire webpage and do ipfire–>pakfire (update) and it updated the firmware successfully.

Yes! Indeed i am using the J5 create USB 3.0 (under red), wireless (blue) and LAN (Green). Check that setting out and reconfigure your network setup.

Actually today, my power supply adapter blew up and i need to get a new power adapter to get this thing fix again.