Core 185 killed my IPFire... again

Thats the third time now, that an update killed the whole machine…
The web-interface is not reachable anymore…
Any suggestions, what i can do now?

EDIT: Fixed it by myself - logged in over ssh and did a reboot.
Is that necessary?
I am not amused…


Sorry that happened to you. I do remember seeing this had happened in the past but I thought it had been fixed before the CU 185 release.

1 Like

Hi, I have the same problem on two IPFIRE MINI APPLIANCEs. While updating to 185 I can’t access them anymore. Internet und VPN are working. The last line in the PAKFIRE Log says, it is “running post-upgrading scripts”. Guess, APACHE needs a restart. Thing is, I am not even neat the two locations, so I can’t access them via the serial cable. Is it safe to simply unplug the devices and starting them? Will they usually do a back-to-normal start, or will I still have to restart apache manually? Thanks for your help.

If VPN is working, can you access it via VPN and reboot it or restart apache?

1 Like

VPN and all other services seem to be working fine. It’s just the WUI which is not working anymore. So I can only do a cold restart (unplug and replug the the device). I could ask a colleague to do this. I can access the network through VPN but as the WUI ist not working anymore, can’t really to anything from here. The question is, will a cold restart also restart the apache webserver or will I have to restart the webserver first and do the restart then.

Can you not access it by ssh through the VPN?

1 Like

No, but I believe SSH had been blocked.

Why? For a remote system with VPN, SSH should be active for administration.

The standard options in the “SSH section” weren’t touched. However, I just tried to access the IPFIRE device via SSH and that didn’t work.

Using the system’s LAN address?

yes. I used the local adress.

If the ssh wui page defaults have been left then ssh is not enabled.

1 Like

The situation is, that I can’t access the IPFIRE appliance, neither WUI nor SSH. I can send out a ping request. So the question is, will a cold reboot (replugging the power cable) help, or will I have to connect via the serial cable and restart apache?

If you connect to a console you should just reboot. It is necessary anyway.
BUT: If are able to researcg the system a bit, it could help to find the reason for this situation. You are using a mini appliance ( from Lightningwire I suppose), this is based on an APU board. I’m using such a board also, as other too. I had no problems in updating ( through the WUI ).


A three fingered salute worked here. (After I plugged in a keyboard) :slight_smile:

1 Like

@ dragonslayr, had to do the same … then it was all good :slightly_smiling_face:

Procedure for updating to 185:

1 Environment assurance:
1.1 Access via OpenVPN (remotely)
1.2 Create a “Connection Scheduler → Reconnect” at a time that is feasible to restart the IPFire.
1.3 Enable SSH and access IPFire via “Putty”.

2 Launch the update to version 185.

  1. When it gets stuck, in the “Putty”, run the command “/etc/init.d/apache restart”

  2. A. If restarting Apache works, you will be able to access the IPFire Console again. B. If it doesn’t work, you will have to wait for the restart planned in point 1.2.

From experience, it is what is necessary to avoid a scare in this update.

Another option is to create an FCrontab task so that at a reasonable time, the command “/etc/init.d/apache restart” is executed and thus, it will not be necessary to do point 1.2 (which will be replaced by this FCrontab) and it will not be necessary to perform point 4B.



To avoid problems with update process output getting stuck in Web GUI I always use the CLI, see screenshot. Works fine for me.


And where did this “yes” on “Reboot required” come from?
When i put in “pakfire status”, Reboot required is set to “NO”

It’s a result of updating from core 183 to the actual 185 with “pakfire upgrade”. So I had to type “reboot” to get fully updated. All without using the GUI, which indeed gets stuck several times, when updating in the past.

1 Like