Cannot change RED configuration settings

I have just installed IPFire 2.25 core 142 five consecutive times (to a brand new, blank drive on a physical machine.) I have been trying to find what I must have missed that is causes any attempt to click on the RED ‘Internet’ connection in the system status to display:

Dialup profiles can only used if **RED** is set to **PPP Dialup** Check the networking setup.

I have looked at Install Step5 but the screen shots do not match what I am seeing. For example, the Network configuration menu I see when I run setup at a root command prompt has the 4th choice as Gateway settings instead of DNS and gateway settings. So something is out of date or going wrong.

Here are my RED interface settings:

I am fairly certain that I have not selected any form of dialup protocol here, but the error persists. I have even tried choosing the other options and then returning to ‘static’ but the error persists.

Hopefully someone can please tell me what I must be doing wrong!

FWIW, I set up an IPFire machine a couple years ago (but the hardware died) and it wasn’t nearly this difficult to get it working back then!

The link for RED on the system home page is for setting up the ppp parameters. Thus the error message this normal for a non dialup connection. ( Using DHCP, I can see it also )

Thanks! I wish the message was a bit more clear about that. It would have saved me a couple hours of redundant setting up today!

configuration/network/dns is out of date. DNS settings have been moved to the Web Interface. The actual setup page you are being presented with “Gateway settings” is now correct. Help on that page does note that the gateway setting is required only for “Static” address on red0, as you are using.

1 Like