Avahi daemon is using 100% cpu resources after updating to core 151

after update to version 151 my cpu usage went 100 per cent.
doing htop from ssh terminal i can see there are two instances of avahi daemon that are killing my cpu.

Which architecture are you running. On NanoPi (ARM7) my CPU usage with Avahi running is only 50% average and 53% maximal.

I do have only one instance of avahi.

Linux ipfire.local 4.14.198-ipfire #1 SMP Mon Sep 28 11:52:54 GMT 2020 x86_64 Intel® Celeron® CPU G3900 @ 2.80GHz GenuineIntel GNU/Linux

I don’t have core 151 on an x86_64. Perhaps someone else can assist

Core151 is not stable released yet so it is only available in testing and unstable trees.

Try to use the avahi from unstable tree. (uninstall avahi, switch to unstable, install avahi and switch back to testing, don’t install the core152 update from unstable for this test!)

unistalled and reinstalled from testing branch

I fired up my old Compaq V3000 (dual 1.6 GHz x86_64) and updated it to IPF core 151 testing.

The console throws an error message about avahi “timing out”, but System log does not report this. The boot completes, after which avahi is reported as running in Services menu. It then does show 100% ongoing CPU utilisation by “user”.

Of more concern is that CPU temp sits at 85 celcius plus, whilst avahi apparently maxes out the load.

I stopped avahi, to see whether this reduces CPU temp to a tolerable 50 celcius, longer term.

The avahi daemon is seriously unresponsive in x86_64:

  • trying “stop” in Service menu had no effect
  • issuing “/etc/init.d/avahi stop” via ssh ditto
  • a console was not available - with avahi locked up and maxing out CPU
  • deselecting “boot” in the Services menu for avahi was the only technique that worked
  • a couple of presses of the power switch were then needed to force shutdown

Fortunately it did complete reboot:

  • with avahi stopped (according to Services menu)
  • CPU usage back to trivial (has only one laptop client, doing not much, on wired connection)
  • temperatures back to normal

i stopped avahi by force closing it from htop in ssh console and my cpu usage back to normal activity.
I unistalled it temporarily. So this look like an issue on testing release 151.

I have asked for the version in unstable branch (avahi-0.8-7) because there is a change that may fix the issues.
If some users have tested this i can pull it to testing…

I have asked for the version in unstable branch (avahi-0.8-7) because there is a change that may fix the issues.
If some users have tested this i can pull it to testing…

pls let me know how to install newst version of avahi whitout upgrade ipfire to 152

I can’t get that to work.

Although /etc/init.d/avahi status reports “not running” any attempt at removing avahi via GUI or CLI locks up the system, which then responds to only a hard power down. Is there some brute-force method of taking avahi out of the manifest of installed packages ?

installing it from unstable brench seems to be ok

i did stop from htop and unistalled form pakfire.

I wanted to let you know that I cannot reproduce this with the version in the current testing branch. Can anyone confirm?

I managed to get a cleanish reboot. Removed avahi executables in /usr/sbin, then rebooted. Got the orange warning message, but hit “enter” and the reboot proceeded.

In testing branch, used Pakfire GUI to remove avahi-0.8-6, then CPU usage & temperatures went back to normal. Booted from a utility CD and ran fsck to see whether /dev/sda3 had survived the hard power downs. It had. Reinstalled avahi-0.8-6 and CPU usage quickly went back to 100% and temperatures in mid-80s.

Partly repeated the process to get rid of avahi-0.8-6, then followed Arne’s advice to install avahi-0.8-7 from unstable.

This is on an old Turion 52L laptop, dual 1.6GHz. It’s supporting one fairly idle workstation. CPU usage of 50% is similar to my production NanoPi running testing branch and supporting a couple of workstations. OTOH, temperatures of high 70’s are not acceptable.

IPF on the Turion was installed at core 143 It is x86_64 from the IMG.XZ file, although installed to HDD.

I installed development build …0dc9 from scratch and switched to testing branch. It exhibited the same 100% CPU utilisation and high CPU temperature.

I though it might have been a resource issue, because avahi was timing out on boot. I now think this might be a case of reboot being needed, following installation of avahi, although there is no message, to that effect. So I doubled the CPU to dual-3.1 GHz, quadrupled the RAM to 8 GB and more than quadrupled the CPU cache, by going to a Core 2 Duo m/c. Also used a later build - latest Master devel build …cd09. That worked with avahi using trivial CPU.

Then went to the previous Turion TL52 box and installed the same latest Master devel build …cd09. That also worked well with avahi consuming trivial CPU.

This is exactly the same build that I tested:

Which architecture?