APU Front panel LEDs doesn't work anymore

I upgraded an old APU unit from v 144 to current and LEDs are not working anymore.


Strange. My APU2 and a friend APU1 are on 173 and the LEDs work as expected. I think in an update of so many versions something could have gone wrong. I would consider backing up your settings and reinstall from scratch the last version. Every year or so I do that just as a preventive measure.

EDIT: you might also want to consider updating the firmware as well.

1 Like

With kernel 6.x you need at least Firmware/Bios to control the leds. The old direct accessing driver was removed from the kernel.


I will try a reinstall from scratch.

First check the bios because the leds based only on one script and the kernel so it is uncommon that this could be incorrect update or filesystem fault.


@jb68 there is a very handy facility in IPFire to update the firmware, however if the firmware is very old you could get this error and the update could not go through. You can read on that page what is the problem.

When it append to me, I used tiny-core burned to a usb stick, booted in to it and from there I did the flashrom update, and it worked.

1 Like

So I used the ipfire utility to update bios, worked on one machine, leds are working :smile:
On the other machine that is older ( ID: 123456789 LOL ) didn’t work, will try with iomem=relaxed