After Core 153, Discord Cam no longer working

My discord cam won’t work on my phone or my Windows 10 desktop. The only thing that changed was updating to 153. IPS is off, still not functional.

Disabled every service for my firewall, nothing fixed it, rebooted and everything. I VPN out of my network, it works again. I use my phone on my cellular network, no issue. Everything worked lastnight, updated this morning, now broken.

Seems to be affecting other things. I’ve noticed some network irregularities while playing League of Legends. So, no limited to Discord. I think this release is botched.

Hi John - welcome to the IPFire Community!

It’s very difficult to figure out how we can help. Can you be more specific?

What was the old version (before update)?

What is discord cam? What does it talk to? (I am guessing just the Win10 desktop & a phone). Does it go thru a cloud service?

You mentioned you disabled every service. What services did you disable? Do you have any firewall rules setup?

You mentioned everything worked last night. What all does not work today?

FYI - I’ve been running Core 153 for a day and no issues.

I went from 152 to 153, I upgrade pretty much on par with releases.

I disabled proxy, Guardian, IPS (suricata), and Location block. Discord and League of Legends (game by Riot) do not work correctly. I honestly am not entirely sure what happened. I only have one firewall rule set and that’s to allow in on one of my HTTPS servers.

I don’t see anything in any logs. I am a software engineer, but this isn’t entirely my area. Let me know how I can help further, it’s just this update broke some things for me.

It’s me and my devices on the otherside of my IPFIRE router and the WAN.

are there any errors on the discord screen? Or the League of Legends screen?

I don’t own or use either and I really don’t know anything about them…

No error on discord, just people reporting my cam is not going through.

For league, I keep getting disconnects, despite I am not disconnecting from my side of the game. So I assume my output is erroring with the server. Seriously, I’ve went through all the logs with a fine tooth comb, not seeing any errors, I’ll need to log into the server directly and review the /var/logs next, but I am too busy at the moment for that.

Can no longer upload to my Nextcloud server. Seems this update has hit many of my services now. I cannot access it from my phone or computer. Which means my firewall rule to allow pass through is no longer honored by the firewall rules.

After doing a fresh install 153, these issues persist except for the NextCloud Server issue.

However, I am just going to move to a different OS. Thanks for your time!

I can confirm that I was having the same problem, and that it only resolved after rolling back to 152. I was having a similar issue with Google Meet. (See discussion in this other thread.)

I hypothesize that there is an issue with DTLS connections in 153. I’ve taken Wireshark traces that show that DTLS connections were not completing on 153 (they get stuck after the first response from the host on the Green subnet and then start over), but do complete with 152.

I added this Discord thread to this Bugzilla item:
https://bugzilla.ipfire.org/show_bug.cgi?id=12563

I have the share image issue with meetings but I’m newbie

I can also confirm that these problems appeared after the update with the following applications for me: Microsoft Teams, Discord, Fortnite.

I updated from core 152 to 155 today.

Here is a new application (Zoom) that I am using and the video is not working properly.

Interesting. I am running 155 and do Zoom calls on a daily basis. Firewall rules are quite strict and I have Suricata enabled for IPS. I don’t run Web Proxy.

Happy to share my settings if this will help you troubleshoot.

1 Like

I saved a discord log file with the problem, I don’t know how to interpret the log file. discord-webrtc_0.zip (12.6 KB)

Could the hardware be causing the problem? I have a Lenovo ThinkCentre M92P. I change my hardware but with the same model, but I still have the problem.

Hi @snipe,

I had a quick look at the log you attached.

Lines containing “Failed to convert device name to UTF8, error = 122” look suspicious. More of a Video / Audio codecs issue rather than IPFire hardware related.

If its just Zoom you are having issues with then you might also like to explore the Zoom Reddit or other Zoom forums for ideas on where to investigate further.

FYI… this is my hardware setup: fireinfo.ipfire.org - Profile 3dbcacf4302069328e9accd0c3731b83c9494c10

Apologies if I can’t be of any more help -or- if I’m way off the mark.

Robert