4G LTE Failover

Hello,

I understand that ipfire can do failover to a 4G WAN.

The documentation here says to use a compatible modem from the list it provides, however, I, for the life of me, cannot see a list of compatible modems.

Failing this, is it possible for me to use on of those LTE to ETH devices that just hands out DHCP lease through Ethernet, and I can set that as a failover WAN 2?

Can’t seem to find any information, I see a page about dial-up settings but I assume that is for talking to a USB modem directly right? Do we have to use a USB modem directly for WAN failover or can we use something like one of these 4G LTE - Protectli (Not for me in Australia but similar device) for the failover WAN?

Hi @knightian,

Yes the link needs to be updated. I will do that. The modems are listed at the bottom of the page at the following link.

https://wiki.ipfire.org/hardware/networking

Ah great thank you @bonnietwin!

Do you know if I am able to fail over to a second ETH WAN or am I required to use a USB modem for failover?

I am guessing from what I am reading that failover is built into the dial-up profile so i am thinking that I must be using a USB modem directly attached is that correct?

Hi @knightian

I’m afraid I don’t know the answer to that.

There was a discussion in the old forum on wan failover. Maybe there is something there that can help you if you haven’t already found it. Beyond that I don’t have any other info.

https://forum.ipfire.org/viewtopic.php?t=5033

I will look at converting this forum posting into a pdf and add it as a link to the Internet Connection page as the old forum will eventually close.

Thanks yea unfortunately it seems there is a lot of confusion in that thread, someone seems to have made their own solution with a script but looks like the script is gone.

I’m guessing that you need to use a USB modem directly for the “official” way of failover, but then again I can’t find any instructions. When I click on dial-up it just tells me that I need to set PPPDial-up on the red interface or something with no instructions on how. Just says 'check Networking setup" but I don’t see anything called networking setup anywhere in the WUI.

Came across this, this might be the goods WAN Failover - A Solution to Offer - forum.ipfire.org

You must use a dialup connection for failover.
A DHCP connection or static IP connection is not a dialup connection.
Failover for any WAN connection is scheduled for IPFire3, as far as I know.

Ok it is as I thought then. If I plug in the USB adapter and select it for red, will it then unlock the dial-up settings page for me?

When I plugged in mine(Vodafone lte modem to USB) to my raspi this strange thing happens…
The connection on wan gets dropped(all clients lose connection to the internet) and also the entire ipfire server is inaccessible(ssh/https)!
So I cannot really tell/see what is happening as I have the raspi headless. The green led on the USB flashes as normal though! The logical consumption here is that this USB 3g modem is NOT compatible and that is OK but why the ipfire seems to reroute everything through this?
Is it maybe a settings problem that I need to have preconfigured(you are able to access its webface from a windows machine) on my USB modem before I try to connect it in my raspi?

Or your Raspberry do not have enough power on the USB to boot up your Vodafone LTE adapter?

because the GREEN LED on the USB flashes as normal then I think that is not a power issue! Also i use this as a power supply https://www.spigen.com/collections/usb-charger/products/4-port-usb-wall-charger?variant=32501610512431 (3 PORTS ARE FREE) so i think is more than enough for my little pi!!! Is there a way on checking if my pi is undervolting through terminal?('m headless!)

Screenshot_1
this is the exact model of the Vodafone modem!

To check for under voltage on a RPi use the following command:

/opt/vc/bin/vcgencmd get_throttled

More information:
https://forum.pimatic.org/topic/4805/detect-undervoltage-on-raspberry-pi
https://github.com/raspberrypi/documentation/blob/master/raspbian/applications/vcgencmd.md#get_throttled