WWAN Profile setup

I don’t know why I couldn’t find the wiki article in the first time. However I tried that and I had to find out that I don’t have any ttyUSB* devices at all in /dev.
Only ttyACM0, ttyACM1 and ttyACM2. The webui modem info says ERROR:

What is that supposed to mean?

That error there means that the AT command was not successful.

It either is that you have the wrong tty selected. Try them all, not all might work.

Or you have no SIM card or the module could not read the SIM card.

OK but shouldn’t I see the device in /dev?
I can’t find any ttyUSB*.
It is working with Windows 10 and the SIM also works fine (just tested it with the installation on it).
I find some firmware issues with that card but can’t find an easy firmware update installation for it but I’m also not sure if that’s the reason why it doesn’t show up in dev.

Edit: my set AT commands are just for the PIN (first) and APN (third). The syntax is as described in the wiki article.

Not every card has ttyUSBX devices. ttyACM seems to be correct in your case, because your have already seen the vendor, serial number and other things on the status page.

Can you show us the dialogue between pppd and your device? That is in /var/log/messages.

OK firmware is 1.2 (Sierra Firmware update service in Windows), but webui says 1.1.11???


Jan 9 14:11:28 MM-NB-006 pppd[5850]: pppd 2.4.7 started by root, uid 0
Jan 9 14:11:28 MM-NB-006 connectd[5852]: Connectd (start) started with PID 5852
Jan 9 14:11:29 MM-NB-006 chat[5871]: timeout set to 3 seconds
Jan 9 14:11:29 MM-NB-006 chat[5871]: report (CONNECT)
Jan 9 14:11:29 MM-NB-006 chat[5871]: abort on (\nBUSY\r)
Jan 9 14:11:29 MM-NB-006 chat[5871]: abort on (\nNO ANSWER\r)
Jan 9 14:11:29 MM-NB-006 chat[5871]: abort on (\nRINGING\r\n\r\nRINGING\r)
Jan 9 14:11:29 MM-NB-006 chat[5871]: abort on (\nNO CARRIER\r)
Jan 9 14:11:29 MM-NB-006 chat[5871]: send (+++ATZ^M)
Jan 9 14:11:29 MM-NB-006 chat[5871]: send (AT+CPIN=“1234”^M)
Jan 9 14:11:29 MM-NB-006 chat[5871]: send (+++ATZ^M)
Jan 9 14:11:29 MM-NB-006 chat[5871]: expect (OK)
Jan 9 14:11:32 MM-NB-006 chat[5871]: alarm
Jan 9 14:11:32 MM-NB-006 chat[5871]: Failed
Jan 9 14:11:32 MM-NB-006 pppd[5850]: Connect script failed
Jan 9 14:11:33 MM-NB-006 ntpd[1730]: ntpd exiting on signal 15 (Terminated)
Jan 9 14:11:33 MM-NB-006 ntpd[1730]: local addr ->
Jan 9 14:11:33 MM-NB-006 pppd[5850]: Exit.

Also the machine says at its startup: “interface red0 doesn’t exist” but it’s listed as defined device for red in the tui setup.

Edit: The wiki says:
" Authentication
Authentication is necessary for some APNs and the username and password can just be entered into their respective fields."

The used ISPs APN does not need any authentication but I must enter a user name, otherwise the webui strikes. Hopefully that’s not why it’s not working.

Edit2: I also wonder about the ^M in the log.

So I tried the same with my Panasonic Toughbook that has got an installed Sierra EM7305, which is working fine in Windows 10 and recognized by ipfire. However I don’t even get any ttyUSB or ttyACM devices listed at all this time and therefor can’t even see any Modem information. I also updated the firmware from the manufacturer without any change in ipfire. :disappointed_relieved:

That device there is simply raising an alarm when the script tries to reset it. So that is the wrong device. Did you try any of the others?

Of course I’ve tried ttyACM0 to 2. Nothing worked for me.

Do they all show the same error message?

The modem simply says it is not ready…

I will try it later, because the SIM slot of the T440s is quite bad and I can get harshly the nano SIM with an adapter to full size into the slot without breaking it.

I just found out (yesterday) that using the Toughbook will be an better idea (battery power 15h) and a little bit more ram + ssd and the same WWAN modem family but I can’t even find the device at all but can be selected in the setup. Any ideas what that is supposed to mean again? :crazy_face:

So I just tested both laptops with ubuntu 19.10 and mobile networking works perfectly with both EM7305 and EM7345 modems so this issue is related to ipdire and not the devices.

For EM7345 there’re for all ttyACM devices the same log entries in ipfire, while EM7305 doesn’t result in any /dev entry at all.

The kernel with its drivers for the wwan cards will be too old (>3y) to work propperly with the devices :disappointed_relieved:.

Did you find out which device NetworkManager is using on your Ubuntu?

Err, no?

Can’t find that information with the network manager of gnome, but there is no ttyUSB or ttyACM device in /dev.

No? :cry:

So I got an Sierra EM7455 for testing purpose and there is nothing new. Works fine with Windows 10 and Ubuntu 19.10, but not with ipfire. There is still no ttyUSB or ttyACM device listet but I can still select the device for the red interface. At the startup ipfire still complains that interface red does not exists, just as with the EM7305 and EM7345. So ipfire is just not capable to run sierra wwan cards at all.

At least this time I found it:

Please check if this devices has a serial only compatiblity mode. (Im not sure.) The IPFire dialup scripts not support config via ttyUSB/ACM and connection via CDC afterwards.

I don’t know: here is the manufactorer information but that’s not much (scroll down) https://www.sierrawireless.com/products-and-solutions/embedded-solutions/products/em7455/

But what do I have to define as modem/device then if not ttyUSB/ACM?
And because I get the driver info when i’m connected to the network “cdc_mbim” should suggest that the connection is done via CDC.

I just tried pfsense and it also doesn’t work. When I was searching for explanations I came up to the point, that newer wwan modems just support QMI and MBIM protocol and no ppp anymore. I also didn’t know that ppp is limited to 25Mbit/s which is ways to slow for my application.

Since there is no QMI or MBIM implementation in ipfire nor pfsense there is no way to get it working.

It didn’t work years ago, and still doesn’t work: https://forum.ipfire.org/viewtopic.php?t=17675

At least the device is there: /dev/cdc-wdm0

I read the article for openwrt: https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle
And wanted to check this step

cat /sys/kernel/debug/usb/devices

But the dir debug is totally empty.

Driver loaded for the device is cdc_mbim so I searched for a command line configuration option:

But ipfire has no mbimcli. The source of mbimcli is available. May I build IPFire with it?

Who says that?

Our kernel has no debugging enabled.

Where can I find the source for it?

I know that some Sierra Wireless modules work, but I am not sure if they are running in PPP mode.

Generally I would like to support these, but it is difficult when nobody of the IPFire devs has the hardware.

Should have read carefully. This will belong to the modem: https://forum.netgate.com/topic/147755/ppp-connection-with-qmi-mbim

May I enable it when I will build ipfire the next time?

As far as I have found out (read a lot of articles) the Sierra Modem after gen 73xx doen’t support it any more and use MBIM. I can confirm that this driver is loaded for my EM7455 with ubuntu, kali and also ipfire. It’s different to my EM7345 of my Lenovo T440s.

I know. But I’m pretty sure all you guys live in or near Mannheim so I can give you my laptop :grin:.

I thought it’s an good and more cost efficient idea to build a mobile firewall appliance for my personal needs with lte wwan and want to terminate the contract of my fixed line because sometimes I’m working on construction sites for weeks till month. It makes no sense to pay for services at home if you’re not at home. The Panasonic thoughbook is not restricted to branded hardware components so I can run any wwan and wifi card I want to. That’s perfect for my needs.

You can, but I do not see what you would gain from this.

The source looks good and I think that all relevant dependencies are already included in IPFire.

No, I do not live anywhere near there.

IPFire is great for that and of course you can connect multiple devices (phones, laptops, tablets, etc.) to the same “hotspot” paying only for one mobile contract.

I am sure we will get it to work.