WUI not accessible after new NAT Firewall rule

Hi. Core 149. Everything Fine until add NAT Firewall rule & Blue DHCP off.
Cannot access the WUI to revert changes using Green LAN or Blue Wireless. Network IP is 169.254.xxx. Ran Setup to confirm DHCP was still checked.

If I could access the WUI, revert DHCP and NAT that should fix the error. But how?

Thanks for your interest.

What is the rule?

Kenneth … @shy-away
if by ip you mean your green network, 169.254.* is not a proper ip (called a link-local ip). Reboot ipfire, connect to the console and you should see the green network having a 192.168.1.* (or some other ip depending on your network setup). You should be able to access ipfire with https://192.168.1.1:444

Hi RadioCarbon. Can’t specifically describe the Rule without accessing IPFire, but I seem to remember what I wanted to send IP 192.166.8.1 to NAT to RED, thereby utilizing NAT on the Blue. Green is disconnected. That IP is the primary internet IP.

You can access the wui on the console via elinks. elinks is not comfortable but it should be enough to disable a not working rule or change dhcp settings.

Hi Arne, Elinks is too big for my MAC experience level: I examined the web page, downloads, and manual. I’ve Serial 10101 - does that offer any command to access IPFire - I have access to Root.

@shy-away
You see me confused.
What is the IP address on green or blue?
Which address is assigned to your client via DHCP?

Login as root to the IPFire and run elinks.
Now it should ask for admin and password.

After this you should get the wui in text mode. Here navigate to network - dhcp.

Navigate with the cursor keys to the Blue network checkbox and select it with space and navigate to save and press Enter.

After this you should be able to connect via blue again because the most operating systems need dhcp on wlan networks.

Hi Arne, elinks opened - great to see that, thought I would have to suffer a learning curve. As the attached image show, according to your directions - got as far as Network - DHCP. But that was it. Could not find any reference to blue. For that matter could not find the Firewall Rule.

At the moment the cursor is in the menu bar. After selecting DHCP Server with Enter once you have to scroll down.

Hi Arne, I wanted to be double sure that is what I did. Still no Luck. When DHCP is Entered it reverts to screen 1/9. The two images for confirmation.

After selecting “DHCP server” the DHCP server page is towards the end of the screen.
You have to scroll down. Top says ‘1/9’.
The menu system is printed always first.
The top line lists which page you will find after this basic menu.
It’s bit confusing, but functioning ( I just tried it :wink: ).

Hi Arne & Bernhard, OK. Back on line. That felt like a Disney ride never knowing around the bend; elinks is like 1980s. Cheers.

1 Like

Just a hint for elinks.
Navigation is a bit easier, if you chose a theme with sidemenu ( maniac or ipfire-legacy ). Thus the sidemenu is locate after the main contents.

Just made a topic in ‘Getting started with IPFire’