With 175 the DNS stopped working

Minutes before on 174 the DNS worked fine but after the upgrade to 175 the DNS is in state “broken”.

[root@ipfire ~]# unbound-control status

version: 1.17.1
verbosity: 1
threads: 1
modules: 2 [ validator iterator ]
uptime: 747 seconds
options: reuseport control
unbound (pid 1874) is running…

[root@ipfire ~]# nslookup google.com


** server can’t find google.com: SERVFAIL

Do not know what i can do about it…

The CU175 update worked fine for me. The DNS page is Working and all the individual DNS servers are all marked as OK.

Nothing related to the DNS system was changed with CU175

Maybe try
ping -c4
This will test if the actual connection to the internet is working.

This will show if your red interface is up and connected
ip address show dev red0

It should show something like

2: red0: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc htb state UP group default qlen 1000
link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
inet yyy.yyy.yyy.yyy/21 brd yyy.yyy.yyy.255 scope global dynamic noprefixroute red0
valid_lft 2619sec preferred_lft 2169sec

1 Like

Thank you Adolf,

today morning i recognized that the modem cannot connect and after a restart the DNS is again up and running.

But yesterday the modem reported to be sucessfully connected and i tried with several restarts and different DNS settings - nothing worked, DNS would not change the state of “broken”.

I will try out your commands next time i come in that situation, thx again!