Wireless mesh router connected to green. How to I access clients from wired clients on green?

I have a small box with two cards running IPfire.
RED is connected to my cable box providing ethernet access.
GREEN is connected to other nic and all wired clients connect here.
I also have a wireless router (three actually, mesh)
The main mesh is connected to GREEN and gets
The wiress router has a dhcp server which gives out IPs to the wireless clients. (192.168.5.X)
All my wireless devices (echos, nest, cameras. all work fine)

one of the clients (a 3d printer, dhcp client connects successfully to the wireless router.

My main PC, cannot ping the device.
I cannot get to the web interface of the 3d printer.

does a route need to be set on PC or a route added to IPfire?



Hello and welcome to our community.

In the scenario you described, the PC and the printer are on different subnets. The PC is on the subnet, and the printer is on the subnet. The PC therefore would not broadcast an ARP request for the printer’s IP address. ARP is a Layer 2 protocol and works only within the same local network or subnet. When the PC determines that the destination IP address is not in its local subnet, it will send the packet to its default gateway for routing to the destination subnet. The default gateway in this case would be the IPFire Router.

Here’s what would generally happen:

  1. The PC would attempt to send a packet to the printer at

  2. The PC would recognize that the printer’s IP address is not in its own subnet (

  3. The PC would then send the packet to its default gateway, which is presumably the IPFire Router, for further routing.

  4. The IPFire Router would need to know how to route traffic to the subnet. If it doesn’t have a route for that subnet, the packet will be dropped.

  5. If the IPFire Router does know how to reach the subnet (through a static route), it would forward the packet to the appropriate next hop, which would be the AP in this case.

  6. The AP would receive the packet and forward it to the printer at

  7. The printer would send the response back through the same path in reverse.

For this to work, you would need to configure routing rules on the IPFire Router to know how to reach the subnet. Additionally, the AP would need to be configured to allow traffic from the subnet to the subnet.


I did try a static route. I did not however change the wireless router.
I will try that next.
Thank you very much for the in-depth explanation.


I added a static route
gateway (IP that wireless router received)
Is this correct? Or should .10 be 1 ( is gateway address for ipfire)

this is correct. This tells the IPFire Router that any traffic destined for the network should be forwarded to the AP at The AP would then handle distributing the traffic within its own subnet (

EDIT: to troubleshoot:

  • Use tcpdump to capture packets on the IPFire Router (and if possible in the AP) to see if packets destined for the printer are being routed correctly. You can also use it on the PC and printer to verify that packets are reaching their intended destinations.

  • Use traceroute from the PC to the printer’s IP to see the path the packets take. This can help confirm whether the packets are being routed through the IPFire Router and the AP as expected.

1 Like

I’m assuming he will also need a port forward in the mesh AP / Router. To allow PC to talk to printer.


Very good point (being the router also a mesh), but I do not think NAT is necessary here. It would only make routing worse. The IPFire Router and the AP should be configured to route traffic between the two subnets without NAT. The IPFire Router would need a static route to the network via the AP (, and the AP would need to allow traffic from the network to the network.

If the AP, being a mesh, is also acting as a router with its own separate NAT, I think NAT should be disabled to allow direct communication between the two subnets. The key principles remain the same: to set up proper routing rules allowing traffic to flow between the two subnets ( and

1 Like

Here’s where I’m at…


Tracing route to over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  ipfire.localdomain []
  2     2 ms     1 ms     1 ms
  3  reports: Destination protocol unreachable.

Trace complete.

also, I can’t get to the web interface of the wireless router
(used to be, but now I think it would be

I connected my wifi on the pc to the wireless router…
So it should still be

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Intel(R) Wireless-AC 9260 160MHz
   Physical Address. . . . . . . . . : 
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Lease Obtained. . . . . . . . . . : Sunday, September 3, 2023 1:30:47 PM
   Lease Expires . . . . . . . . . . : Sunday, September 3, 2023 4:16:05 PM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 278971785
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

The following error was encountered while trying to retrieve the URL:

Connection to failed.

The system returned: (111) Connection refused

The remote host or network may be down. Please try the request again.

The traceroute output suggests that the packet reached the AP at but was unable to proceed further to the destination The message “Destination protocol unreachable” typically indicates that the device (in this case, the AP at could not route the packet to the specified destination.

This does could mean:

  1. The AP does not have a route to the network.
  2. There is a firewall rule on the AP blocking the traffic.
  3. The AP is misconfigured in some other way that prevents it from routing the packet to the address.

You would need to check the AP’s routing table and firewall rules to determine the exact cause.

1 Like

that’s the gateway for, but for IPFire AP is Your problem is in the configuration of the three routers. Make sure they do not do any NAT, and they allow the traffic to flow between the two networks. Watch for firewall rules as well.

1 Like

This is a sadly missing feature in most
Mesh wifi systems. Like Google wifi.
If it is setup in bridge mode it works as a strait AP. No mesh.

solution (maybe there is a better one, but here’s what worked)

Added static route as suggested above on ipfire.
Host IP: gateway:

then, I added a port forward on the wireless router
TCP port 8081 → port 80

Now if I go to web address
I go directly to web page of 3d printer.


well, congratulations to you and @hvacguy

NAT should not be employed here, but I guess we need to adapt to these non-free firmwares.

1 Like