Wireless Kit IPFire Mini Appliance

So I ordered my Mini Appliance 2 days ago and received it already. It’s all looking very nice and I have started the setup.

Now, I think I have read it somewhere, but it’s well hidden (for me) and I cannot find it anymore.

What strings should I use for HT Caps and VHT Caps for the Wireless Kit I bought together with my Mini Appliance?




Yes, on this page, you will find the parameters that we tested well at the bottom of the page. The give excellent throughput and latency by using all features of the hardware that are available.


Hi Michael,

Thanks! Will check into that and report back.
So far impressed by the quality of it all!


It all seems to work okay.

Whenever I select 802.11ac the WiFi-network disappears so I take it the Wireless kit is not capable of that, is that correct?

no, it should work. At least, it does for me.

1 Like

Yes, 802.11ac is supported. Maybe you don’t have DFS enabled or an incorrect channel that isn’t available? The UI is unfortunately not very good in reporting that before it saves any settings.

1 Like

Thanks for replying cfusco and Michael,

First I had to make the setting in the UI (automatic channel selection, just to be sure that wasn’t the problem) and than reboot the firewall. There was my fast ipfire wlan.
And then DHCP on blue stopped working. When I switch back to 802.11gn DHCP has no problem, back to 802.11ac again and clients would wait forever for an ip address.
Fixed ip on 802.11ac works well.
I didn’t find the dhcp-logs yet, so could no further investigate. A quick search gave no clue.
Any ideas?

The DHCP server and hostapd log to /var/log/messages.
You should see the connection of the wireless client to hostapd. Thereafter a DHCPREQUEST/DHCPDISVCOVER for the client ( identfied by the MAC ) should show up. Followed by the answer of dhcpd (DHCPACK/DHCPOFFER).

Hello Bernhard,

Thanks for the reply! I couldn’t find syslog and was in a hurry so I overlooked messages. Thanks for pointing that out.

Solved the problem I think.
I used as an Option value for wpad in DHCP. That should have been “” (so with the quotes). Man, that took me some hours to figure that out, Without the quotes DHCP just stops.
Dunno yet why switching back to 802.11gn solved this earlier this evening as well. I’ll have to test if that is actually true and check the log for clues.

Thanks again.
Have a nice weekend.