Wireless Configuration - Error Message

When trying to disable MAC address filtering on the Blue interface according to this page of the IPFire manual: wiki.ipfire.org - Blue Access - I get an error “Invalid fixed MAC address”.

The Blue Zone is correctly configured and working OK.

Any ideas?

1 Like

Did you put NONE into the MAC address field or did you leave it blank?

1 Like

Thanks Adolf.

Yes I did… here is a screenshot before left clicking on the “Add” button:

Note that I am able to add individual devices OK - just unable to add a full subnet with /24 and NONE.

Note that on previous IPFire builds I’ve been able to add the NONE option on the Wireless Configuration panel no problems.

Also worth noting… I’m not using the BLUE interface for anything wireless. And FW rules setup and the single device (static IP ( on this interface is working fine.

I just checked the code for that cgi page and the change commits that have been applied to it. It has been doing the same thing since before 2014.

If you leave the MAC Address section blank then the code puts NONE into the variable for SOURCE_MAC and that is what is shown in the MAC Address section in the table.

If you put NONE into the MAC Address section then the code see’s that it is not blank and checks that it is a valid mac address. NONE is not a valid mac address hence you get the error message.

That has not changed since at least 2014. I went back to the Core Update 60 code (10 years ago) and the above checks are the same now as then. Also checked the validmac function in the general-functions.pl code from that same CU version and it has also not changed.

So I can’t see how it would have worked with NONE in the MAC address in the past unless some changes occurred at some time in the past and were then reverted at a later CU.

Can you test and confirm with an earlier CU version and let me know the version number then I could install it on my VM testbed and see if I can reproduce it and check out the code for that version.


Thanks Adolf,

My apologies for leading you on a wild goose chase. I just re-read the doco on that page and it clearly states to enter a BLANK in the MAC field. I tried that now and it works like it should.

I must have had a senior moment thinking that I had entered NONE in the past.

I’m feeling like a right old dickhead as I write this.

Thanks for reaching out.


Don’t worry about it Robert.

Been there myself.


For completeness, I just checked the WUI page.
Editing a rule with MAC=NONE doesn’t set NONE into the edit mask. So input, output, processing is connsistent.