Wifi Not Broadcasting

I’m just new to IPFire; switched from pfSense. I was able to install IPFire 2.23 (x86_64) - Core Update 139 with no issues. I created red, green and blue networks. I was able to create DHCP reservations and create firewall rules. My green LAN works without issue. However, when I check my wireless access point controller, my access point is not broadcasting; of course this is my Blue network which I enabled. I’m wondering if something is blocking it? Do I need to create a rule in order to allow my wireless access point to broadcast wifi? Any suggestions would be most helpful. Thank you.

Hi @new2ipfire

for the Wireless network, do you install hostapd addon from IPFire > Pakfire ?

after you install hostapd, you should see a menu entry WlanAP under ipfire (before Logs).
In there you configure ssid, channel, passphrase, and other details.

My computer that hosts IPFire is not configured as an access point. I have an independent access point and access point controller which both are connected to a switch and the switch connected to the Blue/wireless interface I configured. For whatever reason, it’s as if my Blue/wireless interface is not receiving a signal from the Red/WAN interface to be able to broadcast wireless. I hope that makes better sense. I tried a Blue to Red firewall rule and that didn’t work. In the DHCP Server > DHCP configuration > Current dynamic leases, I can see several of my wireless devices. Any ideas?


With everything I’ve done and read so far:

  • hostapd will not install from Packfire. (I’m not sure why I would need to install this when I have an external wireless access point.)
  • I don’t have MAC filtering enabled on my external wireless access point.
  • I can’t seem to find the Wireless Configuration page. Is this page installed with hostapd?

Any more suggestions would be most helpful. Thanks.

Looks like there is an misunderstanding with that:

You won’t need hostapd if your ipfire is not configured to use a built in wifi card for BLUE.

So what do you mean with that? If you can’t find your APs SSID this is related to the device and not ipfire. Actually everything regarding wifi is then relatetd to your AP only.

Just make sure DHCP is enabled for BLUE as well (at least for the beginning)

1 Like

I didn’t think I needed hostapd for an external Access Point.

My AP and AP controller are connected to a switch and the switch is connected to the Blue interface I configured. In DHCP Server > DHCP Configuration, the Blue interface is checkmarked enabled with a start and end address entered.

Oddly enough, the only thing that changed with my AP and AP controller is the firewall. I changed from pfSense to IPFire. That’s it. I can ping my AP’s IP address with no issues. When I login to the AP controller, that’s where I see that the AP is not broadcasting. I’m not sure why at present but I’ve spent hours on it.

Easy thing: connect a device to your switch with BLUE and see if you get internet access and access to ipfire. If that works, you already know that your problem is not related to ipfire.

Also your AP controller is responsible for your AP network/infrastructure. There is no way ipfire can handle anything with that.

1 Like

So I connected my laptop to the Blue switch and received a DHCP IP address; looks good. However, I can’t get out to the interwebs and I can’t get to IPFire.

I think you forgot a mayor thing @arne_f posted already!

1 Like

Ok. My AP is now broadcasting. Whew! I did the Blue Access setup as well. Will I need firewall rules to access the internet on the Blue interface now?

This is all up to your firewall configuration. With defaults, you don’t need any firewall rules.

hostapd is only for wlan cards in the IPFire. If you use an external AP you not need hostapd.
The wireless config page is also only for internal Wlan cards.

The configuration of the Wlan parameters has to be done on the external AP.

Was your IPFire online as you have tried to install hostapd and is the IPFire itself allowed to do http/s downloads. (default it is allowed/outgoing profile)

Thanks to all that responded. I’m back up and running.