Which is the latest version, running on PC Engines APU board

currently the system is running on version 131.
I’ve tried to update several times, but the system crashes if the version doesn’t support serial console

Could you please provide which APU board do you have? Even the bios version, if you know it.

It’s APU 2D0
for Bios I can’t tell at the moment due to homeoffice reasons

I don’t know if there’s any way (on shell) to retrieve bios data. Maybe dmidecode could be a viable path.

Why do you think, that there’s a dependency of the bios version ?
If I perform an update, the next boot arrives at the point, where the VGA should be initialized, and then the system crashes due to the circumstance, that there is no VGA and the master question is, which is the last version of ipfire, which doesn’t require a mainboard with VGA.

BIOS is the translation between hardware and OS. Several years ago i tried to install Windows 7 on an old PC, which by the specs should support it without a doubt. I was not even able to boot the media.

Lo and behold, after a lot of searching, i’ve found that the mainboard was not supporting Windows 7 setup boot method until a BIOS version. Therefore, after a bios update, Windows 7 (even with AHCI) insatalled flawlessly.
Version 132 (or a later one) maybe or maybe not have an updated kernel or something that do not get along with your board.

Just for a wider info for your troubleshooting.

Thx for this information. I’ll be on location tomorrow and figure out the necessary information.

We have removed the extra scon image and included the serial console in the normal flash image. Unpak the image to a flashcard and chose the third option at first boot.

Hi pike_it,

Bios version is 4.0.7

Hello everyone,
I have a suitable question: the installation with the Flashimage Core 144 fails immediately after entering the admin password.
It is an APU.4D4 with 30GB mSATA storage, Biosversion
The installation of the Core 131 works. Updating is also possible. Starting with version 140, the booting process with “Searching Sensors” stops. There is a workaround on the net. However, errors occur afterwards.


we are aware of this issue (please see: https://lists.ipfire.org/pipermail/development/2020-April/007609.html).
However, there is no great solution for this problem; the patchset will most probably be available with
Core Update 145.

Thanks, and best regards,
Peter Müller

1 Like


I got this issue on a fresh installation (with the ISO image). I was able to bypass this issue, via the Flash image with performing a disk image from my usb disk to my msata device (using dd).

Once this operation performed, I was able to boot correctly and go beyond the admin screen password (I got this on my apu2d4). I think the CPRNG is initialized differently on this image.

Best regards,


The issue is not depending on the media. Sometimes it works sometimes not. If the crng hung it need some hardware interrupts. The easiest way to generate some is connecting and removing a usb device from the apu.

Hey everyone
thanks for the helpful tips. Oddly enough, the installation continued on the next attempt until the “Searching for Sensors” message. At this point, however, the hint with the USB stick helped.
With recent reboots there was also no stop at “searching for sensors”.
Thanks and see you then.

The “searching for sensors” issue is fixed in core144.