What is going on? 4 kernel brick in 6 update


I’m using ipfire since at least 8 years and i always loved it.

But i don’t know what is going on but in the last 6 update, the update bricked the kernel 4 times… I’m really tired of re-configuring my stuff and i’m thinking about switching to something else but i want to know if someone else had the same experience.

I’m running it on an old 2013 hp proliant voip server converted to gateway.

Thank you and have a good day!

I have installed IPFire on an the first gen HP Microserver since core99 and none of the updates has bricked the kernel. (I have repartitioned to increase the bootpartition as the updater has reported this.)
Maybee you have an other hardware problem like unstable diskdrive or bad ram.

Also i am aware of one real kernel related bug but this only affect hyper-v and was not really a kernel bug.

Hello Mike @psyco - welcome to the IPFire community!

I’ve not had this type of issue either. I have four IPFire boxes running ( two for only test work).

Does this mean the IPFire went quiet for ~2 minutes (nothing accessible) or something else?

If you can access any of the message logs then maybe the Community can assist.

No, 1 time it was like something tried to read the bash file and was stuck in a infinite loop of gibberish text.

The 3 other time it was an infinite loop of seeing grub, start to boot and something like a kernel panic made the server restarts infinitely. It seems to happen on different parts of the boot sequence.

It happened once on my old machine in like 4 years. Now i run it on the proliant server since a good 4-5 years and was smooth until 6 or 8 last update when it started to crash the installation way too much time…

It only happen when i do an update, if i postpone it continue to work smoothly. When it happen i do a fresh install and it resume to running without problems till i update again.

Let me know if there is something i can do to help track the issue.

Stiils sounds like a corrupting disk or filesystem.
Update is usually the most disk intensive task.
So a system with bad disk usually fail at installing a large update.

You can try to find clues in syslog /var/log/messages and the update logs (/opt/pakfire/log/core-up*.log)
But keep in mind that sometimes this logs are not written if the ssd/hdd fails. If the update logs are empty or /var/log/messages has many non text charakters you may have a hardware problem.


Alright thank you Arne. I have a spare ssd, i will install it and make a fresh install. We will see after the next update.

I cannot look at logs as i already reinstalled on it, so i’ll go with drive problems and try that first.

Have a good day!

1 Like

Just a quick update, i did some testing everytime a new core version of ipfire was getting out and everytime the machine was performing well and was installing correctly from the iso version but when i updated the machine completely bricked. Finally i found that it was not the hard drive that was the culprit it was the RAID controller.

Since i deactivated the raid controller and wired the machine to use the sata controller for the first time i did an update and everything went perfectly as before. I plan on getting a look at the iLO controller to see if i can update the raid controller firmware, maybe that will solve the issue but for the moment the machine is working fine using sata.

So thank you Arne for pointing out the possible cause.


Which is your HP/HPE server, @psyco?
And the RAID controller?