What can be the mistake?

Hello, im facing this problem:
dmz → orange → Ubuntu 20.04 with filezilla-server. Ip: and gateway
green zone → Windows 10 with filezilla-client. ip and gateway

I want to connect from ftp client in green zone with ftp server in orange/dmz.
Im able to ping from green to dmz.
I can ping ( from GREEN):
$ping ( from machine
$ping ( from machine
$ping ( from machine

But i cant reach my objective

I can ping ( from orange):
$ping ( from machine
$ping ( from machine
$ping ( from machine

But as a test i cant reach

.Ipfire setup in firewall, rules is default.
Should not be problem of port as other mates with same configuration have reached their objective…

Seems something is wrong inside ipfire, but i cant assure and i dont know what can be the reason

Any ideas would be apreciated

can you post route from green and route from orange?

Can you explain better please ?

orange has ubuntu 20.04, there is a command, route, which will show the routing table. You can even use traceroute (or mtr to see the steps taken to reach orange from green.

green is win10, I assume there is a route command from cmd, similar to linux.

Thanks for your help… route i assume without any parameters… and traceroute with destination ip similar as ping… am i right ?
Tomorrow ive class with students id answer what you ask for…thanks in advance…

According to the firewall policy green → orange is open. But orange → green needs a pinhole. See the wiki how to make a pinhole. Also check that the win10 does not block something from its default firewall.


ftp is a bad protocol for testing. In some modes the server open a second connection back to the client and this is blocked by the firewall.

1 Like

Sorry for the delay, ive been busy…i finally solved it, dont know exactly how…i restarted all vms and it worked…

That makes me ask ( id open a post not to mix things), that if you are working with different vm, in different zones, should ipfire be the last machine to be started or the first one ? Or it makes no difference ?